Unroot Z10

Discussion in 'ZIDOO Z10' started by Dimasi, Sep 11, 2020.

  1. Dimasi

    Dimasi New Member

    My friends ,

    I want to unroot my Z10 because some apps are detecting that the box is rooted and they don't work .

    Please let me know how to do it .

    I tried several apps with no result
  2. McBluna

    McBluna Well-Known Member

    How did you root it?

    Possible solutions:
    1. Use OnekeyRoot (I've used it for rooting, but never tried to unroot with it. might work)
    2. Update Firmware (I've updated yesterday to Z9S v2.3.35 nd device is unrooted again)
    3. Flash with recovery image (works 100%)
  3. Dimasi

    Dimasi New Member

    Hmm..Ι didn't .It came as it is
    1. I tried it with no luck
    2.To day I will install the 2.3.35
    3. Sorry what you mean and which fw ?
  4. McBluna

    McBluna Well-Known Member

    Btw. it's very uncommon that your device was already rooted when you got it. Did you bought it second hand?

    Did you ever update the firmware before?

    Flash with recovery image is like a factory reset. Your device will be wiped. You'll lose all your settings.
    For more information read here -> https://www.mcbluna.net/wp/zidoo-recovery-images/#z10
  5. Dimasi

    Dimasi New Member

    I got it new .
    Now its on 2.3.30 .If I update to 2.3.35 will be unrooter again?
    I'm afraid to do factory reset to avoid brick ...
  6. McBluna

    McBluna Well-Known Member

    If you don't cut the power during flashing you can't brick it. Since I do a lot of testing with my Z9S I've flashed it already 50+ times over the last year.

Share This Page