UHD2000 new owner: info request

Discussion in 'HDD Media player(RTD 1296)' started by Mirko87, Oct 27, 2020.

  1. Mirko87

    Mirko87 New Member

    Dear Zidoo community,

    it's great to be here posting my first thread!
    I just connected my zidoo uhd2000 and I'm still waiting for hdd's to arrive.

    At first I really didn't like the fact that's not possible to use it as a Chromecast (es. youtube, amazon music hd, from smartphone). About this topic I would like to check whether upnp is enabled in zdmc, but I wasn't able to figure out how. I guess the version it's 18.4 since the firmware is at latest version, but don't have a clue how to check zdmc build installed.
    I will try anything else to get "chromecast" feature, hints are welcome!

    Apk for amazon music was installed but to my surprise, the best supported quality is 24 bit 48Khz: why? Anyone has experienced these problems?

    Gapps from Zidoo (2019 version): play store has no amazon music, spotify, netflix ...

    Another thing not working is ssh via dropbear: connection refused. No way known to me to disable firewall daemon temporarily to make a connection test.

    I also own a usb cd/dvd/bd player (somewhere): will it work on uhd2000?

    thanks in advance to everyone!
    Mirko
     
    Last edited: Oct 27, 2020
  2. McBluna

    McBluna Active Member

    Hello @Mirko87,
    welcome to the Forum.

    ZDMC is not updated with the firmware. Zidoo released ZDMC 18.8 but it's not listed on their download page. You can download it from my site.
    The Google play store offers only the apps the player is compatible to. Most of the streaming apps are not fully supported like missing 4k, HDR or 5.1.
    I'll check regarding the ssh connection. Did you set a password for OpenWRT?
    I'm sorry I can't answer all your questions may be another member step in.
     
  3. Mirko87

    Mirko87 New Member

    Hi McBluna,

    all answers lead by experience are golden to me! :)
    as a new user, I need to better absorb all the technology involved, although I'm not totally newbie, any hint is precious.
    Ok, I will download new ZDMC version from your site and then figure out how to install it correctly :D

    Yes I did set a robust password for openwrt, vers. 15.x.x
    does also OpenWRT and/or other components needs to be upgraded?

    cd player seems not to play nor rip audio cd's.
    dvd's are only playing main menu, then all chapters are skipped as it isn't able to read them... :(
    bd not tried yet (bu I'm afraid at this point!)

    thanks to you and to anyone who reads/answers me :D
     
  4. McBluna

    McBluna Active Member

    I don't have any DVD so this is not my topic. I've only a few BDs and most of them work with full menu. For UHD nearly 99% of them working with full menu support but since I'm German eg Sony, Warner and others are only in English. I've to change audio manually.
    I guess you'll face the same issue as Italian.

    I own a Z9S without the CD-Ripper app but anyway I'd recommend to do all ripping with your PC.
     
  5. Mirko87

    Mirko87 New Member

    up.
    does anyone could answer my questions? thanks
     
  6. Mirko87

    Mirko87 New Member

    thank you very much! your website is very cool and complete!
    zdmc 18.8 made me available audio cd play/rip and dvd video playback :) WOW! that is so comfortable.
    Next thing I would like to do is upgrade openwrt (still not able to access SSH, no clue why) and next install a torrent daemon other than Transmission (e.g. uTorrent)
     
  7. McBluna

    McBluna Active Member

    Thank you :).

    I'm played a lot with OpenWRT. I've even compiled myself but @jjm2473 does a much better job than I did.
    Here is the link to OpenWRT
     
  8. McBluna

    McBluna Active Member

    I'm working on a guide how to update OpenWRT and setup a share.
     
  9. Mirko87

    Mirko87 New Member

    Hi everyone. I reply on this thread just so a UHD2000 user could follow my path in case they do encounter the same problems I did.

    today I installed 2 HDDs, 4 TB each, WD Red NAS (WD40EFAX).
    OpenWRT lets me create RAID 1 but ZDMC stock version File Manager doesn't show it.
    I formatted /dev/satab and /dev/satac as RAID 1, one NTFS partition.

    Is this the correct filesystem? I would prefer ext4.
    Did I follow the correct procedure? RAID 1 is mounted as /mnt/md1 but I don't see it in File Manager and after reboot raid config is lost, despite I saved that configuration.

    I only get HDDs to work without RAID, each one NTFS formatted, but my goal is indeed RAID 1.

    Any help/advice?

    thanks
     
  10. Rajiv Kumar

    Rajiv Kumar New Member

    Hey Mirko I also just got my UHD2000 with 10 TB of WD Hard Disk. I am also a newbie like you and would like to know what all things I can do with my Zidoo player. To start with I would like to install the ZDMC 18.8 from McBluna's site. Just for my information is ZDMC an alternative to Kodi.

    Would you be able to guide me step by step as how you were able to install the ZDMC 18.8 on your Zidoo player after downloading ot from McBluna's site.

    Kindly guide me
     
  11. Mirko87

    Mirko87 New Member

    Hi Rajiv, welcome to the forum!
    Indeed I'm a newbie of Zidoo, but not in Android and Linux system administration :D that's why is so painful not to get some things done, e.g. RAID 1.
    btw if you have two HDDs let me know if you have any luck setting 'em as RAID!
    if you have only 1 hdd, just format it with the filesystem you prefer, I used ext4.

    Here's an outline, for details search the forum and you'll find step by step guides, also look around into McBluna's website: it's full of resources.

    1. Connect your zidoo to the network, better via ethernet cable; run the inizial setup wizard to get the network working.
    2. check your lan (e.g. using PingTools from an android wifi connected smartphone) to see what ip address you zidoo has
    3. let's assume your zidoo has got 192.168.1.101 from your dhcp server, use this address into chrome url from your pc to access OpenWRT
    4. you would have openwrt 15.05.1 likely: here you have access to the most backend features (also HDD configuration, dlna, torrent, services...)

    if you want to go further, then:

    5. first upgrade to the latest firmware, 2.3.35 as of november 2020, download here: https://www.mcbluna.net/wp/zidoo/zidoo-uhd2000-stable-firmware-v2-3-35/
    6. if you brick, check out my other posts on how I unbricked udh2000 succesfully
    7. if you want to upgrade openwrt as well, then you have all the resources here: https://www.mcbluna.net/wp/guide-how-to-update-openwrt-and-setup-network-shares/
    again if you brick, keep ready with the stock firmware on a usb key to do hard reset and re-flash stock system (fw+openwrt) just in case...
    8. after upgrading openwrt you could experience some configuration problems (e.g. web pages become blank, with no more forms to input config for a particular service, to me happened with transmission): in this case, keep the package reset_op to reset openwrt configuration

    my advice is also you to setup ssh access on unspecified port with all flags enabled; last but not least, configure ftp access: that would be useful to transfer contents from your pc to zidoo's internal hdd via network (it also supports external usb connected devices)

    let us know should you have any issue. Have fun!

    Mirko
     
  12. Mirko87

    Mirko87 New Member

    hi @McBluna, hi @jjm2473 ,
    how could I recompile for uhd2000 the latest openwrt version? would you consider worth an upgrade? tnx
     
  13. jjm2473

    jjm2473 New Member

    I noticed that uhd2000 is a rtd1296 device, so you should try z9s op https://jjm2473.github.io/nas/2020/08/26/rtd129x-openwrt-1806.en.html

    If that doesn't work, maybe you want to compile it yourself.
    Here is the source https://github.com/jjm2473/openwrt

    And these packages you will need to touch:
    https://github.com/jjm2473/openwrt/tree/openwrt-18.06/package/system/rtk-android-kmods
    https://github.com/jjm2473/openwrt/tree/openwrt-18.06/package/system/rtk-android-rootfs

    Build guide https://github.com/jjm2473/openwrt/wiki/How-to-build

    If it bricked, check https://jjm2473.github.io/nas/2020/08/26/rtd129x-unbrick.en.html
     
    WhiteShmoo likes this.

Share This Page