Samsung SSD Drive Not Recognized w/ X10

Discussion in 'ZIDOO X10' started by KDA274, Sep 25, 2017.

  1. KDA274

    KDA274 New Member

    Good Morning,

    I purchased a Samsung 850 EVO 1TB 2.5-Inch SATA III Internal SSD (MZ-75E1T0B/AM)

    I mounted it to a 3.5 in holder, plugged it in, and booted the X10. For some reason, the X10 can't see the SSD drive. I've tried unplugging it and reinserting it without success. Has anyone else experienced this problem with the smaller SSD drives?


    DELUCAS Well-Known Member

    Oh thats not good i was looking at getting one of those .
    Are you on the latest firmware ?
  3. KDA274

    KDA274 New Member

    Yes, I'm on the latest firmware version. I'm going to thoroughly check everything again and I'll let you know what the outcome is.

    DELUCAS Well-Known Member

    Have you pre set the hard drive and formatted it for ntfs etc or ?

    Power off box and pull mains lead out for a few mins then re start see if it finds it first .
  5. KDA274

    KDA274 New Member

    I haven't done any of that. I would've thought the Android OS would be able to find it and either format it in it's native form or prompt me to format after bootup. I know, I'm thinking in the Microsoft Windows realm of things and it's not Windows of course. I'll try what you mentioned and see if it finds it when I get home this evening.


  6. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Android can format USB and SD-Card storage devices but it is well hidden under advanced Android Setup (memory and storage).
  7. KDA274

    KDA274 New Member

    Can it also format SSD 2.5 hard drives? I haven't formatted it yet, which is one problem, but Android doesn't even see the device when it's plugged in. It doesn't prompt me to format it as well. I'm just wondering when I get to the location you mentioned, will see it in order to format it?

  8. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Never tried Android format with a HDD or SSD but as I recall format resulted in exFAT which you don't want for a HDD. For an SSD it should be fine.
    Android won't prompt for a format and it won't be seen by any APP. It is only seen by setup storage & memory which will prompt you to format it for you.
    Normally I would not use Android format unless you want to use your SSD as Internal Storage (standard is Portable Storage).

    DELUCAS Well-Known Member

    Did you get the ssd readable on the X 10 ?

    DELUCAS Well-Known Member

    Ok installed my new fresh samsung 1tb ssd in the X 10 no problems but with an external seagate 500gb drive connected as well via usb
    It dont recognise my movie files at all on the seagate .

    But connect a 64gb usd stick it does .

    Is this a limitation of the Android O S ?
  11. HaoSs

    HaoSs Well-Known Member

    no, should work with allot more than 2 attached storage's
  12. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Tried myself up to 12 with and without using an USB hub and that is probably not the limit. Is an Android capability and valid for any recent media player I tried. :)

    DELUCAS Well-Known Member

    Thanks for replies guys

    Think need to set up my ssd properly but waiting for sata - usb cable to arrive .

    Odd i can read a 64gb usb stick
    But not a 500gb portable drive

    Will hopefully tinker over weekend .
  14. WereWolf84

    WereWolf84 New Member

    DELUCAS, does your SSD drive working flawlessly on your X10 so far?

    DELUCAS Well-Known Member

    1tb installed no issues pre set to ntfs
    Installed circa 240 movies etc no issues on playback etc
    Quite opperation .

    Only set back for some odd reason my 500 gb usb drive when connected i cannot see the movies ?
    But 64gb stick i can .

    Still need to have further play or mount drive etc ......

    Thats the only issue ive come across upon fitting ssd in bay .

    But ssd drive works no problems .

Share This Page