SAMBA give partial sharing...

Discussion in 'ZIDOO X8' started by Skyfinder, Sep 2, 2017.

  1. Skyfinder

    Skyfinder New Member

    Device: Zidoo-X8
    LUCI VERSION Powered by LuCI QA160627-nuplayer_Kylin_2017-05-11_SQA_Dailybuild_NAS Release (git-17.130.47916-3e80cb1) / OpenWrt Chaos Calmer 15.05.1
    Zidoo Android ambient is updated
    Kodi 17.3 Kripton installed...

    SAMBA IS ACTIVATED ON in:
    Openwrt options
    Device advanced options...
    Kodi options...

    STRUCTURE:
    • WD 4TB linked via USB 3.0 to the Device.
    • The device on lan via ethernet...
    • Asus Modem / Router... no bullshits about port forwarding, ip... all auto...
    • Desktop: Win10 machine all regular, no crack..on LAN.
    The Workgroup is the same for everyone.

    THE ISSUE:
    When I connect via WIN10 to the HDD...i can see everything. BUT ONLY ONE DIRECTORY SEEMS TO BE BLOCKED, I can't rename, rewrite, paste... say:
    "You need the permission by ZIDOO-X8/nobody"

    The directory is the largest, with the biggest number and dimension of files... the movie directory -.-

    Tried hard reset from android and from openwrt...nothing... WHAT THE HELL????

    I tried to change something to the template file via backend...nothing:
    This is my file:

    [global]
    netbios name = |NAME|
    interfaces = |INTERFACES|
    server string = |DESCRIPTION|
    unix charset = |CHARSET|
    workgroup = |WORKGROUP|
    browseable = yes
    deadtime = 30
    encrypt passwords = yes
    enable core files = no
    guest account = nobody
    guest ok = yes
    invalid users = root
    local master = yes
    load printers = no
    map to guest = Bad User
    # max protocol = SMB2
    min receivefile size = 16384
    obey pam restrictions = yes
    os level = |OSLEVEL|
    passdb backend = smbpasswd
    preferred master = yes
    printable = no
    inherit owner = yes
    create mask = 0777
    directory mask = 0777
    force create mode = 0777
    force directory mode = 0777
    security = user
    smb encrypt = disabled
    smb passwd file = /etc/samba/smbpasswd
    socket options = TCP_NODELAY IPTOS_LOWDELAY
    syslog = 2
    use sendfile = yes
    max xmit = 65535
    max connections = 8
    dns proxy = no
    writeable = yes
    vfs objects = posixacl
    aio read size = 0
    aio write size = 0
    # strict allocate = yes

    For what I found on the internet, seems that I have to add and set a new user via SSH... BUT i'm still wondering why this problem affects only ONE FOLDER?! I have another folder with big files and big dimension, no problem...the folder is not locked under Windows...if I connect the HDD to the PC, everything is ok.
     
  2. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    Do a openwrt factory reset, and try again, ( this will wipe all openwrt custom settings ).
     

Share This Page