Please walk me through Samba access from my PC to X10

Discussion in 'ZIDOO X10' started by Master, Feb 10, 2019.

  1. Master

    Master New Member

    I don't remember how I made it working but I had been using Samba and I used to be able to access (rename, copy, move, delete and etc.) files on X10 (not just internal HDD but also USB sticks and external HDD) from my laptop (Windows 10).
    I still see below network OpenWrt connections on my computer folder.
    Disk_sda1 (OPENWRT (OpenWrt)), Disk_sda2 (OPENWRT (OpenWrt)), Disk_sdb1 (OPENWRT (OpenWrt)) and Ext HDD - Disk_sdb2

    Somehow after moving to new home, when I doubleclick them I get error message, for example, "Windows cannot access \\OPENWRT\Disk_sda1".

    IP address of my laptop and X10 are and, respectively and both of them are on WiFi.
    Default gateway:

    Last night, I updated software to version 2.1.22 hoping this may help to no avail.

    I do have access from laptop Chrome to X10 at below address though.;stok=3ab31d1aa6ebed89dafa7fb618f22ae7
    Below information is kind of screen capture, which I hope it can help you walk me through to resolve this issue.


    System OpenWrt
    Model Realtek_RTD1295
    Load 3.66, 2.44, 1.06
    Memory 1629.08 MB (1559.36 used, 69.71 free, 4.16 buffered)
    Local Time Sun, 10 Feb 2019, 00:39:03
    Uptime 00h 04min 03s

    Hostname: OpenWrt

    Shared Directories
    Enabled Name Path Write









    Of course, I checked all the boxes of shared directories enabled and write.

    Lastly, I am not interested of accessing files on laptop from X10 though.

    I appreciate your kind help in advance.
  2. HaoSs

    HaoSs Well-Known Member

    they messed with the nams of the share, you need to go in openwrt. where the samba share is, and rename " Disk_D0F6A7ADF6A79270 " back to '"Disk_sda1" /2/3/4 etc.
  3. Master

    Master New Member

    I need to rename Disk_D0F6A7ADF6A79270 to Disk_sda1, for example at X10?
    How can I do that?
    Thank you.
  4. teidybugi

    teidybugi New Member

    I managed to get samba working today (first time using it) and I believe it helped that I've enabled SMB 1.0 in windows, because after new updates its disabled. After that I followed the guide, I had to manually put my IP address when searching for SMB on zidoo, and it worked. I'm still surprised it works. Not sure if this will help, since the topic started in February, but just wanted to share my experience.
  5. Master

    Master New Member

    Thank you so much, teidybugi, for your kind help.
    However, I still couldn't get it working and have given up.
    Best Regards.
    PS Sorry for the delayed response.
  6. HaoSs

    HaoSs Well-Known Member

    a little older but still valid
  7. Master

    Master New Member

    Thank you for your kindness. However, when I make SAMBA connection over a network drive, the error message tells me I am blocked. Anyways, thank you so much.
    I've got FTP connection working though by resetting password.
    I was using SAMBA connection until firmware update though.
    Last edited: Sep 6, 2019
  8. HaoSs

    HaoSs Well-Known Member

    reset openwer from openwer settings or from x10 settings and try again
  9. Master

    Master New Member

    I did reset openWRT on X10 settings but I was getting an error message as below when I tried to map a network drive.
    You can't access this shared folder because your organization's security policies block unauthenticated guest access. These policies help protect your PC from unsafe or malicious devices on the network.
    I modified the setting on Lanman Workstation and enabled unsecured guest log on. And, this change allowed me to establish SAMBA connection.
    Thank you very much.

Share This Page