Playing MP4 films with Zidoo x9 and Kodi

Discussion in 'ZDMC for Zidoo' started by papiguy, Jul 20, 2015.

  1. papiguy

    papiguy Member

    Kodi is working well on Zidoo X9 but I do not understand why
    - MP4 films are played correctly while selecting them with the Explorer
    - playing the same files with Kodi starts (with images and sound) and stops after 2 or 3 seconds.

    Properties of the files are:
    - container : Quicktime
    - codec : MPEG-4 AAC
  2. Scott

    Scott Member

    What did you use to determine the container ?
    I have several formats of files I can try a test to see if I get same results . Have you tried running the file through mkvmerge ? I have been told it can fix odd things with video files to fix them when they will play one way but not another.
  3. papiguy

    papiguy Member

    Thanks for your answer Scott,

    I used the file explorer of Ubuntu 14.04 LTS.
    VLC shows for the same file: Codec : H264 - MPEG-4 AVC (part 10) (avc1)
    Popcorn A410 shows : AVC for video, AAC for audio - resolution 1920x1080 16:9 - 50.000 fps - 1080p.
    All the concerned files were recorded by an Avermedia Game Capture HD2 from a satellite box. Curiously the extension of the file is .mp4 and not .mov which the Apple's one. More over, Avermedia device cannot play other files than those recorded by this box.
  4. papiguy

    papiguy Member

    As playing starts for a few seconds, I supposed that the problem was linked to the speed of the network. After activating WIFI (the RJ45 being still connected), I noticed a change in the display: play during about 5 seconds, then buffering, play during less than 5 seconds, then stop.
    Using only WIFI (RJ45 being disconnected) the system does not work properly, as above.
    I went into my network configuration and found an old 10/100 switch !
    So I tried to bypass the network by copying the film on the USB device and adding the relevant path to Kodi. Then the system works perfectly.

    Then it appears that the problem is still there, not linked to the container or the codec. Users having only WIFI, or a network not gigabyte, will have the same problem for HD video files.

    ps: at the beginning of the play, after the first stop a small window appears showing bufferisation, then the play restart and then stops again. It could be a problem of management of bufferisation within Kodi (time-out ?).

    Last news: In order to identify correctly the reason of this issue, I Carefully reviewed my network, identified a switch 10/100 and replaced it by a gigabit one; the result is exactly the same, while I assessed the transfer rate has been increased.
    Last edited: Jul 24, 2015

Share This Page