New firmware v2.1.40 version for ZIDOO X10 release

Discussion in 'ZIDOO X10' started by McBluna, Jun 15, 2020.

  1. McBluna

    McBluna Active Member

    Last edited: Jun 19, 2020
  2. Mariusz

    Mariusz Member

    Someone was installing?
     
  3. zarathoestra

    zarathoestra Member

    At first seems stable only ht3.0 and series aren't the best friends:rolleyes:
     
    Mariusz likes this.
  4. Mariusz

    Mariusz Member

    Thank you very much for the information.
     
    zarathoestra likes this.
  5. Mariusz

    Mariusz Member

    I will repeat after a colleague from another thread.
    Had anyone tested if the HDR to SDR conversation bug is solved?
     
  6. zarathoestra

    zarathoestra Member

    Well i tried several hdr movies over the network SMB to an sdr television went well so in my case it's ok.
     
    Mariusz likes this.
  7. Heavymetal

    Heavymetal Member

    I can't get smb to work for years now,how did you do it ?
     
  8. Mariusz

    Mariusz Member

    zarathoestra, Thank you for the info.
    And generally new software works well?
     
  9. zarathoestra

    zarathoestra Member

    Living room connect zx20 pro on wired network with orico usb hard drive 40 TB - upstairs x10 connect wired network just make sure your on the same network if you work with router pull out cable and connect directly to x10. let it do the scan and try eventually you can put it back to your router but make sure it is wired otherwise with wi-fi you get hick-up in sound and connectivity. Must say had several attempts and reboots to make it work and i repeated the same with HD dune player and Oppo clone M9703 works like a dream. With windows pc it's a different case no luck yet .
     
  10. zarathoestra

    zarathoestra Member

    Like i say i do mainly movies and series and works very stable for me.
     
  11. Mariusz

    Mariusz Member

    Thanks a lot,
    then installs.
     
  12. Heavymetal

    Heavymetal Member

    Yes i know,with windows 10 i can't get it to work,thanks for the reply.
     
  13. zarathoestra

    zarathoestra Member

    Good luck;)
    Not at all;)
     
  14. ursiel

    ursiel Active Member

    I installed v2.1.40 over the weekend, and played (or tried to play) a couple mkv movies.

    The first one was 4k/HDR and it had lots of loud audio pops. The audio track was DTS-HD Master Audio 6-channel. The video was HEVC x265 - 10bit Main 10@L5.1@High, frame rate 23.976. I couldn't even watch it - I quite after a few minutes. The video didn't stutter and no dropped video frames, but the audio would suddenly have a loud pop. I then played the file plugged directly into my TV using it's built-in media player, and it played flawlessly with no audio issues. So the file is fine. My PC plays it fine too.

    The second file was a 1080p blu-ray remux (23.976), and about 2/3 of the way through, the frame rate suddenly turned into a stutterfest, looking like a stop-motion film. At first I thought it was the film using a fancy slow-motion/stutter effect as it happened during a dramatic part, but then I paused it and then un-paused it and it played normally for the rest of the movie. Checking the scene again afterwards it was not the film, but the player as it played fine when I checked that scene again.

    I've had tons of issues with audio dropouts and loud audio pops with this player, since I bought it way back, but the stutter issue with the blu-ray remux is unusual and I haven't seen it before this latest firmware. I keep hoping another update will fix it but it never does. Sometimes files play through fine all the way, and sometimes it's fine until part-way through, and sometimes it's a problem right from the beginning.

    I play the files using a USB 3.0 thumb drive plugged into the player using Media Center from the home page, not Home Theatre.
     
    Last edited: Jun 30, 2020
  15. Mariusz

    Mariusz Member

    Have you ever tried using Kodi or another movie player?
     
  16. zarathoestra

    zarathoestra Member

    Looks more like an handshake issue ,audio source soundbar or something else ? Like stated above try with another player from friend or whatever with exactly same cables and see what is does.
    So you can out rule the devices that giving those pop sounds or hick-ups.
     
  17. ursiel

    ursiel Active Member

    Well I said I played the file directly using my TV as a media player (it has a built-in media player) and it played flawlessly straight through. I have also tested previous "problem" 1080p files for the Zidoo in my other older media players like the Mede8er and WDTV Live, and they always play fine. This has been happening since I bought the player like 2 years ago. Files that have audio pops and drops play fine in other players. It's clearly a Zidoo issue.
     
  18. ursiel

    ursiel Active Member

    No, I don't use Kodi or other media players. I've played with it a bit in the past but there were things I didn't love about it for my needs. I don't need to build a huge media library. I copy a file over to my USB temporarily, watch it, and delete it off the USB card. So I don't need anything fancy.

    The built-in media center player should work without major audio issues. I shouldn't have to use 3rd party players to solve the issue. I've heard this suggestion in the past. Using another player isn't fixing the problem.
     
  19. zarathoestra

    zarathoestra Member

    So it's a hardware issue then return it to fix it . no firmware is gonna resolve that kind of issues. Good luck
     
  20. ursiel

    ursiel Active Member

    Lol, return it. I've had it for like 2 years.

    It is not a hardware problem. It's a firmware problem. The hardware is functioning fine. If it's a handshake issue, that's on the firmware. And we don't know that it's a handshake issue - that's just a guess. It seems to handshake fine. The problem is it has audio glitches galore.

    By the way I owned an x9s before I traded it in for the x10, and that also had the same issues back then that the x10 had after I got it. No surprise as it's basically the same player. Obviously some things have improved a lot with updates over time, but this audio drop issue is not one of those things that improved.
     
    Blackbeen likes this.

Share This Page