KODI randomly crashes - FW .13 .25. and .28

Discussion in 'ZIDOO H6 Pro' started by Majorasshole, May 18, 2018.

  1. Majorasshole

    Majorasshole New Member


    I'm experiencing since the beginning with my H6 Pro shipped factory flashed with .13 firmware, and consecutive updates (including after a factory reset) a random crash of Kodi at start.

    This issue mainly occurs when some apps have been launched before (as Netflix, or Spotify), and with many forks an vanilla releases. I tried KODI 17.6, 16.1, Leia Alpha SMPC and FTMC. One time or another, I get the same punishment. Kodi launches and stops to respond nearly instantly. If everything is killed in background, it mostly works.
    Kodi 18 test builds don't even launch and crash instantly.

    My setup is quite simple : 1080p TV and projector, and SPDIF audio with passthrough enabled. I tried many configurations (including audio passthrough disabled, or disabled mediacodec's acceleration, and removing SD card storage), and it still occurs randomly. Then the only way to recover a up and running device is to restart it, or unplug it.

    Beside that, most apps run flawlessly including Netflix 6.x (rooted and unrooted firmware doesn't make any difference, and it occured even with rooted with the 4.xx Netflix, Spotify, or in fact any noticeable application in backgroud).

    It's really annoying, even if I'm convinced this device has great capabilities thanks to it's DRM certifications and a decent ability to handle HW decoding, and gives a lacking feature of Shield : SPDIF !

    Somebody experiences the same problem ?
    Last edited: May 18, 2018
  2. denir70

    denir70 New Member

    Hi I can confirm the annoying instability registered when launching Kodi.
    Most of times (whatever firmware version is running, from 1.0.11 onwards), Kodi crashes at startup and the tv box moves into a deadlock state. The only way to recover from the deadlock is to power-off / power-on the tv box.
    Not a pleasant experience at all.
  3. dikonomi

    dikonomi Member

    I installed Kodi 18 a few weeks ago but it wouldn't open, so returned to 17.6. It works fine, has crashed some times, but not at start and not while playing movies. When it crashes, the two options, close app or wait, do not work, I press the button with two squares and then <- or -> to close the opened programs. It occurs rarely though and as I said before Kodi 17.6 works without problems.
  4. Victor Shocot

    Victor Shocot New Member

    check your internal space
    when was almost full kodi keeps crashing to me
    cleared the internal space and since than it works great

    V18 didn't start either
  5. Majorasshole

    Majorasshole New Member

    It's not related to free storage as this behaviour occurs when I've plenty of free space, and even whithout a library. It's a sudden crash that mainly occurs when apps have been launched before Kodi, so it's very suspicious as all other services run flawlessly. And the impossibility to launch Kodi Leia is also quite suspicious to for the future...
  6. Majorasshole

    Majorasshole New Member

    I can add Simply Radio with the exact same random crash at start with apps in the background...
  7. sunnyk

    sunnyk New Member

    Kodi is simply not well supported on AllWinner SOCs


    Zidoo isn't gonna do anything about it either.

Share This Page