How to visit aria2 remotely on webui

Discussion in 'ZIDOO X9S' started by francishe, Nov 25, 2016.

  1. francishe

    francishe Member

    Zidoo tech
    Please instruct how to remotely open aria2 on webui and what the port mun? I have DDNS, which opens transmission well.
     
  2. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    once you activate aria2 from openwrt interface. it will have a button. " open web interface "
     
  3. francishe

    francishe Member

    Yes, it works on Lan. I wish to know how to visit aria2 on Wan. Usually there is a visit port say 8081. Here I can't find the port mun in http://XXXX/webui-aria2.
     
  4. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    go in aria2 settings. there is a port. 6000 something. you need to add it in router with the box ip. and it should work
     
  5. francishe

    francishe Member

    That is the rpc opening port 6800, not the visit port. I remember it is something like 8081, say http://xxxx.3322.org:8081
     
  6. francishe

    francishe Member

    Sorry, 9100 doesn't work.
     
  7. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    yah. thats why i deleted the post. tried miself and did not work..
     
  8. pcristi

    pcristi New Member

    http:// <ip_player> /webui-aria2/
    [​IMG]
     
  9. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    we are trying to acces it from internet. We know it works on lan
     
  10. francishe

    francishe Member

    Yes, it works on Lan. We are talking about how it will work on Wan. Where is Zidoo tech? they should know.
     
  11. Are you trying to access the aries2 web gui from over the internet?
     
  12. francishe

    francishe Member

    Yes, from out of Lan with DDNS. Do you have any good idea? Say Transmission, you can visit it either on Lan or Wan by entering its DDNS+9091(visit port)
     
  13. The port for aries2 webui is port 80. You would need to port forward your router with port 80 pointing to the ip of your zidoo box. But port 80 is a common port so its better to use another eg. 8080 or 8081 or any other port that is currently no being used. Then point the outside port (eg. 8081) to the local port of 80. See attached image..

    Then you would access you Aries webgui with the following address http://ddns:8081/webui-aria2
     

    Attached Files:

  14. francishe

    francishe Member

    Thanks, I did as what you advised pointing 9100 to port 80.
     
    Last edited: Nov 28, 2016
  15. francishe

    francishe Member

    By the way, do you have any trouble of failing to open aria2 or losing download list after reboot?
     
  16. I am not currently using Aries2 now so I can't comment. Just offered the solution above as I have used this method for many other webgui's (not zidoo related) I wanted to access remotly without having the abillity to have a visiter port.

    Are you still having sucess with your sleep 60 command
     
  17. francishe

    francishe Member

    Yes, successful. To be honest, once running it works stably. Another problem still troubling me. The setting "force-save=" can't be set. When set to true, it returns to default "false" after reboot.
     
  18. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    now i fell just stupid.... of course is port 80.... it's fu*king obivious .... how i did not see that ?
     
  19. francishe

    francishe Member

    So did I. I have used aria2 for years, which usually has a visit port number other than 80. So I was fooled by my experience and forgot 80 might be. I tried many ports usually assigned to it and none of worked. Then I came to look at 80.
     

Share This Page