Geforce NOW crashes on X9S 2.1.40

Discussion in 'HDD Media player(RTD 1295)' started by Gaben, Sep 5, 2020.

  1. Gaben

    Gaben New Member

    Hello Everyone,

    I've tried Geforce NOW (installed from Play Store, so newest version) with my X9S on ver.2.1.28 1080p60, auto bitrate and it was working just fine, although it had some render issues, occasional ghosting, discoloration etc, so i thought i upgrade to ver.2.1.40.

    On this version after like 1 or 2 frames of video and 1 second of audio the box crashes back to the loading screen (animated zidoo title) and restarts after a minute. I tried it with 1080p60, 720p60, 720p30 with auto bitrate and 720p30 with fix 5mbit bitrate, same results all the time, crash after the first frames.

    Any idea guys? I really like my box and i don't want to buy a console when i can buy 4 years of Geforce Now on the price of a used PS4.

    To the devs: Can i help you somehow triage this problem, e.g sending you a crash dump maybe?

Share This Page