DVD playback is completely broken

Discussion in 'ZIDOO X10' started by ursiel, Mar 1, 2018.

  1. ursiel

    ursiel Active Member

    I originally posted this in the x9s v2.0.5 firmware thread, as I originally owned the x9s, but I was asked by several users to create separate threads highlighting some of the more serious issues with these players, to bring it to Zidoo's attention. Now that I own the x10, I see this player suffers from all the same issues as the x9s. There's a wealth of information on these issues in these 2 threads for the x9s:


    So here goes:

    DVD playback is completely broken:

    - When playing NTSC (29.97) 4:3 aspect ratio DVDs (VIDEO_TS or ISO, or individual VOB files), video is "stretched" horizontally. It is not stretched to 16:9, as there are vertical pillarboxes (black bars), but it is not the correct 4:3 aspect ratio, as the pillarboxes are not as wide as they should be. It's half-way between 4:3 and 16:9. It is completely distorted and there is no way to fix it. Hitting "menu" brings up an option under the pop-up menu on the left for "aspect ratio" but the 2 options are:
    - "full"
    - "fit"
    Neither option displays 4:3 correctly. "Full" stretches the image to 16:9, and "fit" displays the image partially stretched.

    - When playing PAL (25.00) 4:3 aspect ratio DVDs, the opposite is true - the video is "squished" horizontally, resulting in pillarboxes wider than they should be. Again, neither "full" nor "fit" displays it correctly. "Full" stretches the image to 16:9, and "fit" displays the image partially squished.

    - Same holds true for 16:9 NTSC and PAL content - it is "squished" horizontally into the same broken aspect ratio - in-between 4:3 and 16:9. You have to hit the menu key on the remote and force the aspect ratio option to 16:9 to force it into the proper 16:9 aspect ratio.

    To put it simply, regardless of the disc's aspect ratio, the Zidoo forces all DVD content to a weird "in-between" aspect ratio - neither 4:3 or 16:9. So both ratios are broken for DVD playback.

    How is this an issue a year+ into the player's firmware? How has this not been discovered and fixed already? Am I really the only one who has discovered this, or has this just been ignored? This is a deal-breaker for me and I will be returning this player ASAP if this can't be fixed quickly. Many people still have large collections of DVDs and DVD files. If a media player in 2018 can't get basic DVD playback figured out, there's something wrong.


    - The navigation bar is broken for DVD ISOs. In a 1 hr, 46min film, hitting the right navigation key on the remote skips to 35:28, 1:10:56, and 1:46:25 (end). That's it. In a 25 min TV episode, I cannot skip in the navigation bar at all. There's no way to go anywhere else in the video. I have confirmed this with multiple DVDs. The numerical keys do bring you to the percentage of the film, so it's the navigation bar that is broken. The navigation bar seems to work "okay" with DVD VIDEO_TS folders, though the navigation bar is choppy (not smooth) and a bit hard to get where you want in the video. It's not as precise as with mkvs, mp4s, etc.

    - DVD menu navigation was broken in one of the PAL DVD ISOs I tried. You could not see any indicator in the DVD menu as you moved from option to option. If you hit "ok" on the remote it would activate the option you were on in the menu, but there was no way to see what option I was on since moving the remote's navigation buttons weren't having any visual effect on-screen (no arrow or highlighted text of any kind like you usually see in DVDs and blu-rays).

    - You can't navigate or skip warnings or other junk (studio intros) when DVDs start playing. Hitting menu doesn't work. You have to sit through them.

    - Cannot hit "menu" key on remote to bring up the player's menu options when on the DVD menu page. You have to start playback first.

    - When clicking on a DVD ISO file, it thinks it's a blu-ray file:
    "This file may be a bluray image file,Please choose operation to be performed.
    Blu-ray menu"

    Hitting "Play" still brings you to the menu, just like hitting "blu-ray menu".

    - When clicking on a folder with a DVD VIDEO_TS folder, it thinks it's a blu-ray folder:
    "This is a Blu-ray folder. Please make a selection
    Blu-ray menu"

    Hitting "Play" still brings you to the menu, just like hitting "blu-ray menu".

    - I also installed the latest ZDMC and set it up, then tried playing those same DVDs in ZDMC. The aspect ratio is correct in ZDMC but both NTSC and PAL have constant stuttering every few seconds, making it unwatchable. This is with the Zidoo's options set to HDMI auto, and I also tried it with HDMI 1080p@60Hz.

    All of this combined makes DVDs an exercise in frustration and unplayable. Can the Zidoo team please, please look into this?
    Last edited: Mar 1, 2018

Share This Page