Disney+ not working

Discussion in 'ZIDOO X9S' started by Ekul, Sep 13, 2019.

  1. Ekul

    Ekul Active Member

    On Zidoo i get error " can not play video"
    On other Android machine it works ok.
    I guess drm is still not working?
    What a terrible box this is.
     
  2. SaskMedia

    SaskMedia Member

    In defence of the box it’s meant for watching local content.. it wasn’t made to stream stuff such as Netflix or Hulu. If you want a strong streaming device I’d recommend the amazon fire devices or an Apple TV.
     
  3. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

    ...or Xiaomi MI Box S...
     
  4. Fidodido

    Fidodido New Member

    I can play netflix on my zidoo x9s. So jou can imagine, thate it is possible.
     
  5. bob79

    bob79 New Member

    Hi, may I ask how did you install it, because via googleplay it's restricted?
    I assume you installed the apk manually, but does it work in FullHD or 4K?
    If not it is worthless.
    The problem is Widevine L1-3 is still not a part of zidoo's android, I faced this issue with my Z9S when I wanted to use HBOgo in kodi.
    I installed the addon successfully, logged in, but I figured out that when I attempted to play a movie, it just simply failed without any notice.
    Further I discovered in the .log that it was unable to reach the media DRM folder in android.
     
  6. bob79

    bob79 New Member

    Hi Ekul, you don't have to guess, just install "DRM info" from playstore and you will see that there is no any widevine DRM Level.
    It should be the part of android, unfortunately it cannot be installed as in linux or windows.
    However i like my Zidoo Z9S very much for playing all my home media w/o any problem.
    But the widevine issue bothers me.
     

Share This Page