Can't play [any H.264] video

Discussion in 'ZIDOO X10' started by zoori, Jul 7, 2019.

  1. zoori

    zoori New Member


    I decided to write this message of last resort before I throw my Zidoo X10 away. I do hope that someone in this forum will be able to help me out, since I enjoyed my X10 very much. The problem is that a couple of days ago, out of a sudden, it stopped playing all videos encoded with H.264 - basically, most of my library. It plays sound, but shows only black screen (on-screen menus still appear), and after 10 seconds or so displays "Can't play video" and returns back to Media Center or Home Theater. And that happens with all videos that I tried. Interestingly, the player still runs videos encoded with HEVC/H.265. I was on fw 2.1.22 when this happened, did not change anything prior to that. Tried upgrading to fw 2.1.25, downgrading to 1.4.12, upgrading to 2.1.25 again, multiple resets/factory restores, connecting to different TVs, opening videos from external drive - to no avail. That makes me think that the actual problem is not with software, but with hardware. Any thoughts would be very much appreciated.
  2. teidybugi

    teidybugi New Member

    Have you try switching stream player in the settings?
  3. zoori

    zoori New Member

    Yes, if I remember correctly, there was a choice between nuplayer and native, I tried to switch and it didn't help... I might give another try tomorrow
  4. teidybugi

    teidybugi New Member

    When I switched the player I had to reboot zidoo to apply it and then it worked. But can't speak for H.265 how it works, but I can play HEVC movies (4K HDR) with no problems.
  5. TEAfest

    TEAfest Member

    Tried to reflash it again?

Share This Page