Install TWRP no PC (need root)

Discussion in 'ZIDOO X6 Pro' started by Vu Asia, Apr 4, 2016.

  1. Vu Asia

    Vu Asia New Member

    here is my steps to get TWRP:

    1. root your X6

    2. Download TWRP recovery IMG for RK3368 (~5.4 MB)

    3. Download Flashify free to the X6

    4. Flash the recovery img by Flashify (grant root), when done click rebbot to TWRP.

    5. All done.

    video from stock to TWRP recovery

    the IMG is from here, if you have no root, need PC to install

    PS: backup/Restore work fine, can flash back to stock recovery img if need. Xposed v80 dont work, black screen.

    try it at your own risk.
    neamielu and PacoRabanne like this.
  2. grummel2005

    grummel2005 Well-Known Member

    what is with all the data and stuff which is on the device?
    will it be deleted?
  3. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

    Understood, thanks!

    Only a few curiosity:
    1. who is the maker of this TWRP image?
    2. Do you know if FlashFire (similar product but made by the Master chainfire - ) will flash it succesfully?
    Thanks a lot!

    What a pity, I've already tested Xposed some month ago (using FlashFire) with very same result... I hoped that latest Xposed was compatible, but seems not yet :(
    May Zidoo can help Xposed developer?

    AFAIK, nothing is touched, recovery image is saved in another "partition".
    But of course if the device doesn't boot no more, you need to a "recovery procedure" (flashing a full ROM image) and in this case you lost all...

    Else we can wait Vu Asia answer.
  4. Vu Asia

    Vu Asia New Member

    1. the IMG is from, the OP show a little note about dev Abdul's img. Yes, nothing is touched, recovery image is saved in another "partition". nothiing delete.
    2. I see FlashFire can't flash recovery img directly, look like it should work if you convert the img to a .zip to tell it which partition to flash.

    hope someone could make xposed work on X6 soon, need youtube adaway.
  5. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

    Not completely good: flashing was OK, reboot in standard way OK, reboot in recovery OK, but after using "clean dalvik cache" and "clean cache" gave an error, then when I've rebooted X6, stuck on boot logo animation.
    Now I reflash last img.
    As Zidoo developer said, TWRP is still not ready for X6...
    grummel2005 likes this.
  6. grummel2005

    grummel2005 Well-Known Member

    thx for the live-test
    that is what i thought when i asked - is it save?
    let us wait then ...
    thx a lot paco!
  7. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

    You're welcome! ;)
    Reflashed 1.0.33 (thanks cyber7 for FW link!), rooted, a lot of work to restore my minimal apps configuration (my bought apps saved my life!), now I'll update to 1.0.34 (downloaded, not yet online OTA, maybe another release is on the go ???).
    All apps seems OK, but I must check if ZDMC is again "OK" :D, seems it's the "black beast" o_O:rolleyes:
  8. Vu Asia

    Vu Asia New Member

    Where is the function "clean dalvik cache" and "clean cache" ? I double checked that I can wipe cache/dv. cache by using menu Wipe -> Advanced Wipe -> click check box cache+Dv cache -> done and reboot (longer time for booting after wipe cache+dv cahce) you can install liveboot by master chainfire to see

    Edit: you should always backup rom first, in bad case (boot loop, black screen... when I try xposed), you may manual boot X6 in twrp to restore your rom. that's how twrp useful for.
    Last edited: Apr 6, 2016
  9. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

    Don't worry, a clean install from time to time is always good on Andoid device used for experiment (like all mine).
    For me need of TWRP recovery is firstly binded to a functioning XPosed framework. Until this yearn moment I can wait for Zidoo developers (hoping they are still working on it)

    OK about do a NANDroid backup before a risky job, but how to access recovery on X6 if it stucks on boot logo? No power/volume button...
    Or there is another use of reset hole that I don't know?

    P.S. good idea to install Liveboot!!!
  10. Vu Asia

    Vu Asia New Member

    how to manual boot X6 in recovery mode:

    1. disconnect ALL power source (plug out power wire, usb cable x6 to pc)

    2. put a small stick to reset hole and keep pushing in

    3. plug in power wire (NOT USB CABLE) while still pushing in reset hole. after zidoo logo ~5 secs, you should boot in recovery mode
    PacoRabanne likes this.
  11. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

    Info to keep saved!
  12. Xoxi Xiola

    Xoxi Xiola Member

    Will twrp able to flash firmware updates?
  13. Harlan

    Harlan Active Member

    True enough, but you can also use the "Recovery" button on the Zidoo Update app to boot into recovery mode too. The stock interface only allows you to do a few chores without a PC. Obviously, this won't work when you are soft bricked or caught in a loop.
    Last edited: Apr 10, 2016
  14. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

    Harlan, thanks for clarification, but my question was
    how to boot an X6 in "recovery mode" from "power off" state
    because in my case my X6 was (or I presumed was) in a "boot logo stuck" status.
    I was testing TWRP recovery, and may be my presumption was wrong, and any boot on X6 after a "wipe cache" and "wipe dalvik cache" keeps very long time.
    To be clear, I'm not a novice in flashing ROM, modding device and "cleaning" (wipe) cache, I know that every time caches are wiped there is a long time to rebuild some file, bu there is always a popup window with progress. I was in a very early phase, and usually in that phase a stuck logo is symptom of soft bricking...

    I'd like very much to know other brave user experience on installing TWRP as instructed by Vu Asia
  15. Harlan

    Harlan Active Member

    I hadn't actually used the Zidoo X6 softkey Recovery button until yesterday (if it isn't broke don't fix it). Some chipset vendors install a stock recovery that permits you to backup user and system data partitions using the elevated privileges available to the copy of adb on the recovery partition, see for example the (Alpha) release notes for the Zidoo X9. Needless to say, that's NOT possible right now with an X6. Although it warns you to backup your data before an OTA update (as if it had the recovery feature advertised on the X9), there's no way an ordinary luser account holder can actually do that on an unrooted X6 box (and a properly packaged OTA update should abort on one that's been rooted in the first place).

    My advice to anyone who isn't already rooted and fully backed-up would be to just wait. The state of your individual box's firmware seems to depend upon whether or not you've started out with the .19 FW .img and applied all of the incremental OTA updates versus the .33 FW .img

    The .33 I'm running today, after a factory image flash yesterday, is not the same as the .33 FW I was running just a few weeks ago. For instance it doesn't have the keyboard selection feature mentioned in the user guide here:

    There are a number of other annoying differences, that in my case, caused me to decide that it would be best to just go ahead and root my X6 and make it work for me, instead of the other way round.
  16. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

    Harlan, I agree with you.

    I'm however sorry that with rooted device some app refuse to run.
    I'm currently under a timed promotion to try a TIM (italian provider) service, TIMEntertainment, available on smartphone or tablet, and all my device are rooted, and dedicated app refuse to run.
    X6 is a "virtual" tablet, so all these app should run.
    Rooted device is not the way to pirate pay contents, "true pirates" uses special HDMI HW device to do the job....... not chinese TV box!!!
  17. Vu Asia

    Vu Asia New Member


    as I said at the beginning, can flash back to stock recovery img if need (stock recovery by Zidoo). I've use Flashify to flash back to stock zidoo recovery for the official zidoo OTA and firmware update job. It should be safe and like stock as possible.

    TWRP have save me a lot of time to restore everything back perfect after testing .35 firmware (or maybe any other future firmwares I dont like).
  18. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

    OK, thanks a lot!
    I like TWRP, installed in ALL my other Android devices, so I like very much to have it also on X6.
    I'll try again with more patience ;)
  19. marthaxd

    marthaxd New Member

    Is it safe to use other apps like 360 root for rooting ?

Share This Page