ZDMC 18.8 on Z9S

Discussion in 'ZDMC for Zidoo' started by JBA6, Sep 1, 2020.

  1. JBA6

    JBA6 Member

    For those who may be interested I can confirm that this latest version of ZDMC is compatible with the Z9S. With it's default settings, locally stored video files are passed through to the native Z9S video player with Dolby and DTS sountracks being detected correctly. HDR modes also appear to work well.

    Music playback is gapless as it always has been with ZDMC or Kodi but all tracks are resampled to 48KHz so if this is important to you, use Zidoo's Music app or another instead.

    ZDMC v18.8 http://apidl.zidoo.tv/app/zdmc-18.8_rtk.apk

  2. McBluna

    McBluna Well-Known Member

    Thank you for the feedback. I've just tested if the apk is installable and ZDMC starts.
  3. TheFonz

    TheFonz New Member

    I can confirm that v18.8 can also be installed and starts on the X9S.
  4. Marwan

    Marwan New Member

    I downloaded zdmc v18.8 to my Z9s and installed it. When I went to check ZDMC version it was still v18.4! What am I missing? Do I need to uninstall it first?
  5. JBA6

    JBA6 Member

    I didn't have ZDMC or Kodi installed when I ran the new ZDMC 18.8 installer so yes please do try uninstalling the old version first.
  6. Marwan

    Marwan New Member

    Yes it worked!
    Thanks a lot
  7. ThomasP

    ThomasP Active Member

    Nice surprise after the last statements. And it works on the Z1000 Pro.
  8. H. S. Narula

    H. S. Narula New Member

    Hi. I'm a new owner of Zidoo, Z10. I have a number of questions if anyone can help me

    I currently have 1 unit with Hard Disk installed

    Can I access the files/movies in this unit from another Android TV/ If so how, and what software do I need to use? I cannot seem to access this from my Macbook, even though the IP address is correct. Any way to fix this?

    IF I purchase a second unit for a 2nd room, can the 2 units communicate with or access each other's files? Or will each unit be limited to its own hard disk?

    I can access my NAS server from the zidoo, but my phone and Mac and my OPPO which can all access my NAS cannot see the Zidoo

    Maybe I'm doing something wrong? I'm a novice, so any help would be highly appreciated
  9. McBluna

    McBluna Well-Known Member

    @H. S. Narula
    Did you create a share in OpenWrt? Open http://<ip of your Z10> in a Webbrowser.

    If you've setup your internal HDD as share each player should be able to access it.
  10. 3DBuff

    3DBuff Well-Known Member

    Once you setup Zidoo to share the drive from @McBluna instructions it will work just like your other NAS. Zidoo has excellent transfer speeds up and down at max Gigabit network 110 Mb/s. Probably better than your other dedicated NAS drive.
  11. H. S. Narula

    H. S. Narula New Member

    Hi, Guys,

    Thank you so much for your assistance. Did the OpenWRT as per suggestion, but was already open for sharing, so still not really successful, but let me explain my system

    Network: TP-Link Deco 5 Mesh wifi
    Zidoo Z10 (new) (8tb internal, 2TB external USB HDD, both full) in living room
    Cocktail Audio X10 (CX10, to avoid confusing Z10 Zidoo in living room)
    Oppo 105 connected to HD projector in Home Theatre
    Buffalo NAS in Home Theatre connected via ethernet to the TP Link
    MacBook Pro moving around,
    Sharp Android TV bedroom
    Sony Android TV Connected to Zidoo, living room
    Samsung Note 10

    All except NAS are connected wirelessly to the same wifi network

    On my Note 10, I CAN connect to Zidoo, CX10, and my NAS, using X-Plore, but when I scan, the Zidoo is not visible, I can only connect when I add with IP address. Then I can see everything, both the drives and all titles in the drives, and can even watch the movies on my phone.

    On my OPPO, connects to NAS, and CX10, Z10 not visible. No option to input IP address, so that's out
    MacBook Pro, connects to CX10 and NAS, but scan/browse does not show Zidoo and IP address, says CANNOT CONNECT, ask your Admin....
    On my Sharp TV, cannot scan/see the Zidoo, physically can add IP address under X-plore and Kodi, but when I try to access the hard disk, returns timeout error message. Tried the same on my Sony TV, same result

    The fact that my Samsung Phone under X-plore allows me full access to all the functions indicates to me at least that OpenWRT is not the issue, would I be right to say that? I can access all devices and even play back movies from Zidoo HDD on my phone, no problems. Could my difficulty in accessing all the info on my Sharp and Sony TVs be the result of too much data on the HDDs and too little memory in these devices? My Note 10 has lots of memory, so maybe this is the problem?

    My Zidoo is able to access my NAS and also access the CX10. So this part is great.

    Being a novice, I am looking for a more idiot (me) proof solution, so my question is, if I purchase another (lower end) Zidoo device, no HDD, can I surely connect to the first Zidoo? Of if it is with a HDD will the units intercommunicate? If yes, I'd rather just do that and not have to work around all these issues.

    Another issue, can I set a FIXED IP for the Zidoo? Problem on Friday, had a blackout for an hour, and when the system restarted, ALL my devices had new IP addresses, so had to change all the setups, so for these am looking to fix the IP address, any problems if I do that, and any tips on this, what to do, what to avoid?

    An option, I CAN if necessary and beneficial add a TP Link satellite mesh unit and then connect the Zidoo to the mesh network using ethernet cable, WILL this make a difference? I am assuming not, but just want to be sure.

    Sorry for this long post, I am sure there are answers in the forum somewhere on these topics, just don't know where to look.

    Alternatively seem moving ALL my files to the NAS would allow ALL my devices to access all the files? Maybe, if memory on the TVs is not the problem, which cannot be increased.

    Its a lot more difficult that I imagined frankly

    Thank you in advance to anyone who can provide any assistance and tips
  12. H. S. Narula

    H. S. Narula New Member

    Additional information:

    Managed to connect my Macbook to Zidoo HDDs using cfis://ipaddress instead of afp://ipaddress. So this looks like it should work fine, altho did not try to transfer files.

    I read about this tip on this forum, so thanks to the person who posted that tip

    OPPO still cannot 'see' the Zidoo
  13. 3DBuff

    3DBuff Well-Known Member

    @H. S. Narula, I don’t know all devices on your network and protocols they use but I think the key problem you are dealing with is different file sharing standards you have.

    Zidoo will share files using SMB (Samba) protocol. It’s like browsing files on remote hard drive using network path with some security levels. Your Sony TV won’t do it no matter how much memory it has. It doesn’t have network file browser app. What Sony TV can do is to read media files from DLNA server. This is limited access to selected media files only more like live streaming similar to YouTube streaming.

    A lot of NAS devices can be set as SMB file sharing and DLNA servers at the same time. Based on the program you using to access this device you can either read lists of media files and play them or use full file explorer program to see, play, copy and move files.

    Programs like Kodi can read most of network protocols. The preferred connection would be SMB. This allows Kodi for full unrestricted access to files scanning for media info like resolution, fps, audio type and extracting screenshot if needed.

    To sum it up you need to sort it all out. Your TV and some other devices need to have active media network servers like DLNA. I have LG TV and my media files from various locations on my home network are fed to Zidoo connected to the TV. I don’t use TV to browse for files for that very reason. It will only see media servers and not networked drivers. If your collection is small you could probably use DLNA server but with larger multi locations it won’t work. Zidoo’s HT and Kodi will scan all multiple locations on my network and present my collection with posters, synopsis, artwork and ratings. I don’t want a list of files from my TV browser.

    Yes, you can use static IP but even better if you reserve IP in your router DHCP table. It will always assign the same IP based on MAC address. In Zidoo’s OpenWRT set network name to something like ZidooZ10 so you can log into it using \\ZidooZ10 (PC File Explorer) rather than IP address. Sorry don’t have Mac. Hard Wired LAN Gigabit is always better.

    I hope that’s enough info to point you in the right direction.
  14. H. S. Narula

    H. S. Narula New Member

    Had a busy few days, sorry for the delayed response.

    Your post has been very helpful, but also as I try different things I am beginning to understand better what the options are, and things are starting to look up a bit. We live and learn.

    Right now, finally my Mac connects to my music server, the Zidoo Z10, AND my NAS, so this was the good news. For those who may have a similar problem, the Macbook connected to the Zidoo using cifs://ipaddress. SMB would not work. But its working using cifs, and that's the good news. In any case this is for copying files or moving them around, not for viewing, so I'm OK in this regard now.

    Forgot to mention I have multiple Apple TVs all over the house, and family has multiple iPads so I managed to connect my iPad Pro to all these devices using FE File Explorer Pro on my iPad, and can watch all the movies as well.

    Last thing I need to try is if my Apple TV can connect to everything, using FE File Explorer Pro TV on the AppleTV. Hope this works. Will post my experience.

    My last hurdle is how to connect my OPPO to the Zidoo, it can connect to everything else. It sees the NAS, my music server, but the Zidoo IP never appears so no way to connect, but still working on that

    If it doesn't, then I'm going the lazy man's route and going to get additional low end Zidoo units for each TV, then I don't have to try to understand networking, altho I have learnt some new tricks the last few days.

    This is a great forum, and thank you to everyone who has posted tips and tricks. Even tho replies may be limited there is a whole encyclopaedia of info on how to make the best of Zidoo TV, and all those who have helped post their tips are deserving of a big THANK YOU
    3DBuff likes this.
  15. ElvisC

    ElvisC Member

    I had some problems using this
    It did not recognize the network, I had to add it manualy

    Which KODI version it this based on?

  16. TheFonz

    TheFonz New Member

    According to the settings, ZDMC is using the external player from Zidoo. What I do not understand is that when I start a bluray movie with menu contained in an iso file I get the option to start the menu (see screenshot), however when I choose this option it just starts one of the titles. I downgraded to 18.4, but the same problem also exists in this version. Is this by default not working or are there other settings that should be enabled/disabled to get this to work?

    Attached Files:

  17. 3DBuff

    3DBuff Well-Known Member

    That's how ZDMC / Kodi works. This is an open source program and decoding of Blu-Ray menu requires licensing.
    Home Theater from Zidoo is the way to go if you want BD menus.
  18. H. S. Narula

    H. S. Narula New Member

    Interesting things I learned over the last few days.

    My OPPO finally CAN access the Z10. That was a relief.

    However, when I try to play back MKV files on the Zidoo, which I got ripped by a vendor, I can play them fine on my Z10, can see them on my OPPO, but when I try to play I get 'FILE NOT SUPPORTED message. Strange. But when I try to play back MKV files on my NAS, which I ripped myself using MakeMKV, it works just fine.

    Not sure if the issue is accessing the Z10 or there are different file formats for MKV. Playback of MP4 files on my OPPO from the Z10 is , MOSTLY, OK. MOSTLY because I haven't found one yet that didn't play back, but haven't tried all.

    But playback of 1 particular MP4 title I ripped from my DVDs using WINXDVD, I have different versions ripped, some say FILE FORMAT NOT SUPPORTED, then 1 rip says VIDEO FORMAT NOT SUPPORTED. The VIDEO NOT SUPPORTED file, I get the audio after this, but still no video.

    But ALL of these play back fine on the Z10.

    ARE there different variations of MKV and MP4 files? Why all play back fine on the Z10, but some do not play on my OPPO I am still trying to figure out.

    Not sure if this is due to file transfer from the Zidoo over my internet connection, but MP4s from the Zidoo playback fine, but (almost?) all MKVs do not.

    We live and learn! Its been interesting, to say the least
  19. 3DBuff

    3DBuff Well-Known Member

    MKV is a type of file container. It can hold different types of audio and video types of compression (Codec). Oppo is is not universal media player. It will decode and play most of videos but not all. Zidoo is much better in decoding almost all formats. ZDMC/ Kodi should decide them all. Kodi player on Zidoo box is not working well. Lack of proper hardware support will make it stutter and drop frames all the time.
    I hope this helps.
  20. H. S. Narula

    H. S. Narula New Member

    Yes this certainly now makes more sense. Thank you for clarifying.

    Is there a way, or program, to check what codec is being used in a particular file? That would solve a lot of mysteries. Technology can be very confusing at times.

Share This Page