Z9X HDD showing unsupported over usb after trying everything.

Discussion in 'HDD Media player(RTD 1619DR)' started by Masterjeff, Aug 22, 2023.

  1. Masterjeff

    Masterjeff New Member

    Hello, I recently got a new seagate 8tb hdd (model ST8000DM004) to use with my zidoo over usb with a sabrent sata to usb 3 adapter. However despite all the ways I try to format it with windows it shows as unsupported and asks me to reformat, and when I do it shows unsupported by windows. I have tried gpt+ntfs via windows with both direct sata connection and usb to sata adapter and neither worked, also tried with minitool partition manager and that did not change anything. Does anyone have any advice?
  2. Phil181

    Phil181 Active Member

    You are on the right track by using GPT partition and NTFS formatting. They definitely work with Zidoo for external USB and internal SATA connections (I have many formatted that way and regularly swap them around).
    Do you have a different external HDD case or docking station to check the adapter is not faulty? Perhaps another hard drive to test?

    How are you seeing it as an "unsupported" drive? Have you tried to add as a "Source" in Home Theater 4 or does it show up as a drive in Media Center?
    Using Android/Linux to format as EXT4 would mean windows cannot easily view or write to the drive.
  3. Masterjeff

    Masterjeff New Member

    I tested it with a different sata to usb adapter and it worked fine, thank you very much, I made the mistake of assuming all would work the same.
    rozel likes this.
  4. rozel

    rozel Well-Known Member

    Been their and had the t-shirt but really pleased you got sorted. I have 2 NAS's and after going full-fibre with a new router, I assumed the wiring to a switch would be the same - nope! After 3 days trying to work out how my Z1000Pro could not see them nor my PC, I worked it out. Sometimes these things can be so frustrating :rolleyes:

Share This Page