Confirmed aggregated problems FW V6.3.12 (no feature requests)

Discussion in 'HDD Media player(RTD 1619DR)' started by Nice Monkey, Jan 1, 2021.

  1. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    I will (try) to aggregate pending problems/bugs with the FW6.3.12 here.
    Items fixed with FW6.3.2 were removed. Also removed some mere "nuisance" type of problems which are considered inconveniences. The focus is on the more serious items and features directly claimed to be included. Will keep updating it with any new FW released for all models.

    Things confirmed as fixed will be marked green with the actual FW release and be removed with the next FW update available for all models. Assigned numbers will be kept.
    Please don't forget to report items you think have been fixed too!

    Hot items are displayed in red. These have a big impact at least for the users relying on a bugged existing feature which must have been introduced later. Not for new features under development or things which never worked correctly before.

    Things not working as one likes or feature requests are not to be included. Just matters not working as advertised/claimed.

    Problems must be repeatable and confirmed by several persons. They also should implicitly apply to all RTD1619DR based models and any TV/AMP being used (excluding all DV and VS10 related issues) unless stated specifically.
    Use my Z9X purely for validation being a clean machine with no add-ons installed.

    1. BD menu processing:
    BD Menu processing works mostly (my guess above 95%). The nasty thing is that BD Menu's mostly fail (getting stuck) when you need/want them to work most being with multi-cut version BD's, with Multi-Episode/Multi-Movie BD's/BD Pure Audio albums as you need the menu for these to select the desired playlist/track.
    Problems with BD-Menu are very common also if the menu is multi-language which is more often the case with recent movies including UHD.
    The workaround is just starting default longest track playback without BD menu and then going to the BD Menu option for direct track selection. That will mostly do the trick to still getting the desired track to play.
    Some BD's you can start from "the chapters selection" as a workaround rather than "play movie" if it returns back to the main menu selecting play.
    2. DVD menu and playback processing
    DVD-Video menu processing has multiple flaws including turning subtitles off and these are there since the beginning for all Zidoo player models and generations. It just never got enough attention. The nasty thing is that DVD Menu's are always processed and can't be bypassed. In almost all cases one can still get the movie to play and it is just annoying.
    DVD-Audio Discs (with MLP HD Audio in the AUDIO_TS folder) is not supported and never will work without perfect menu processing as there are many ways interactive menu's are being used with these discs for track and feature selection during actual playback. For that same reason DVD-Video compatibility for DVD-Audio discs does often not work either making playback totally impossible.
    3. Music Player problems with mainly HD FLAC sources being 24-bit (88.2, 96, 176.8, 192)
    This with output set to play source formats up to 24-bit at 192 kHz and HDMI/SPDIF output set to RAW.
    MP runs into CPU limitations relative quick. Must be the way drivers are programmed. I can simulate this by doing a Filetransfer via SMB in the background. Also simple FLAC playback via the DAC may then show mentioned sound problems. Video Player seems to use far less resources as it plays fine even with SMB transfers in the background.
    3a. DSD => PCM conversion with HDMI output is still 16-bit instead of 24-bit.
    Not being part of the problem reported it is excluded but considered a related flaw.
    DSD 64 outputs as PCM 176/16 bit via HDMI
    DSD 128 outputs as PCM 88/16 bit via HDMI
    DSD 256 outputs at PCM 44/16 bit via HDMI
    4. Kino Lorber BD movies not finding the single subtitles included (mostly EN)
    When playing without menu the player reports no subtitles found. When playing with BD Menu though there is an option for toggling subtitles ON/OFF which works then just fine.
    This could be Realtek SDK related? All movies of Kino Lorber have this problem. KL is famous for releasing large quantities of restored classic movies.
    https://www.klstudioclassics.com/
    9. MP does not support UTF-8 when reading tag files.
    Only English is displayed normally. National symbols (Russian for example) is displayed as Chinese characters.
    10. MP does not play all DTS-CD's correctly
    About 1%-2% of discs just play in 2CH and a sporadic number just produce noise. All play fine using my OPPO.
    12. 3D not triggered when playing 3D-BD ISO with Menu.
    - When you only "Play video", output in 3D is triggered, and playback is smooth
    - But when you "Play with Blu-ray menu", 3D is not triggered and movie plays only in 2D
    13. Playing a movie with a DTS-HD track adds 2-channels in info. MA 5.1 soundtrack, displays as DTS-HD 7.1 etc. DTS-HD MA 1.0 (so in mono) as info gives DTS-HD 3.0. Other ones in DTS or Dolby Digital are ok.
    14. SMB performance not optimal. Several reports of problems with above all heavy network load movies. Problem can be reproduced playing UHD ISO's using SMB not happening via USB/SATA. Using the same files played on other brand players with the same SMB server and LAN do work flawless and even more curious also UHD MKV play fine too. Rollback to 6.0.45 and they are gone is reported. This seems partially fixed/improved but still many claiming not as good as on previous generation SOC's. Moving from SMB => NFS seems to solve the problem at least for some. QNAP SMB Servers seem to suffer from this the most.
    15. Netflix giving an 1044 error when play is started. Netflix applied apparently a ban on actual movie playback with the Zidoo player producing this error when tried. It seems Dune & Himedia players now got that same Netflix treatment too, so unlikely to be fixed. Instead the Netflix APP is expected to be removed from FW distributions.
    21. Roon certification problem
    Roon seems to be compatible as claimed but Roon also validates certification of the player using it which seems to be not complied with yet.
    22. No play with no error when trying to play SACD MCH only DSF/DFF/ISO track/album.
    Tracks will be just skipped and no action taken which is extremely confusing as it is impossible to see if it is 2CH or MCH. It should pop-up with "Unsupported format" or something similar.
    23. UHD3000 plays 2.0 PCM 96/24 or DD True HD in slowspeed via DAC when a e.g. a Music BD is played.
    Does not happen with HDMI output and neither playing the DTS MA HD tracks. MP6 plays PCM 96/24 and other 24-bit PCM formats correctly.

    Please don't start discussions here, do that in the FW release topic itself or start a dedicated topic for it. Just mention items you think that should be on the list. I will aggregate them next after reading the relevant material and/or reproducing myself.
     
    Last edited: Jun 19, 2021 at 7:38 PM
    Thanos, jmmy, fsim2000 and 5 others like this.
  2. mirror

    mirror Well-Known Member SUPER Administrator Zidoo TECH Supporter

    3. Music Player playing 16-bit only with HD Audio sources being 24-bit (88.2, 96, 176.8, 192)
    Checking. will check AMP EDID for 24bit output.
    and will add Dop via HDMI function.
     
  3. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Thanks for the confirmation. :)

    DoP (=DSD over PCM) via HDMI will be a mayor MP innovation when achieved. Above all if it is going to include MCH DSD? :cool:
    This will make MP a true SACD capable player. :p

    Update: Seems it was meant for DoP via USB (not HDMI). Nice if having an external DAC. Maybe HDMI is still to follow next?
     
    Last edited: Feb 20, 2021
  4. Whitfield

    Whitfield Active Member

    gymnos likes this.
  5. Inikad

    Inikad Active Member

    5. Languages of HT and GUI conflict
    Impossible to set 2 different languages in GUI and HT4.0 anymore. The language of the GUI will become the language for the scrape in HT after a clear data/backup restore in HT4.0, or if you change the language of the GUI in the settings and restart your player.In any case, it will go back to english by default if the GUI language is set to english. Before, you could set 2 different languages in HT and GUI settings without any problem.

    6. Return Remote button in poster wall
    In certain conditions, you can't use the return button of the remote to go back to the first movie of your collection. When "Classification mode" and "poster list alphabet navigation" are unselected in HT4.0 settings, to get a simple poster wall when opening the app, the function doesn't work anymore.

    7. TV Series scrap accuracy (in french, other languages to be confirmed)
    When you scrape your TV Series in HT4.0, the accuracy is extremly low, no matter if the names of the episode respect the TMDb nomenclature and if the same files gave a perfect match in HT3.0 with older zidoo players. Over 10 french users have confirmed that problem on a french forum about Home Theater stuffs. Example of the nomenclature used for the show The Mandalorian: "The Mandalorian (2019).S01E01" (same result with "The Mandalorian.S01E01").
     
    Last edited: Jan 1, 2021
    gymnos likes this.
  6. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Sorry, but I won't include TV model and/or DV/VS10 specific issues here. Enough posts for that already. Stated also in the top entry.
     
  7. ulna68

    ulna68 Active Member

    definitely yes, I look forward to it with longing, I have a couple iso SACD with multichanell
     
    Cineast likes this.
  8. Yaniv Dayan

    Yaniv Dayan New Member

    Can't paly UHD movies. Playing normal Blu-ray works fine, but when trying to play UHD movie, the unit fails to send EDID info to the receiver and you don't have picture or sound. The only way around it is to use the resolution button.
    Also allot of issues switching between 4k resolutions in home screen. Sometimes 60Hz works, sometimes 30Hz works
     
  9. Inikad

    Inikad Active Member

    8. Clear system application Data not restarting the media player
    Usually, when you use "Clear Application Data" in the Quick Settings ( with all the external sources unplungged), the Zidoo player will restart automatically and it will display the "Welcome initial Settings". Now, it doesn't restart by itself and you have to do it manually. The Factory Reset function works properly and restarts the player as it is supposed to do.
     
  10. Mabon

    Mabon Active Member

    Can we get the wording right guys - "scrape" and "scrap" are two very different words in English with very different meanings.

    (1) Scrape / Scraping / Scraped: gathering and copying of data from a website.

    (2) Scrap / Scrapping / Scrapped: discard, abandon, abolish, remove or throw away

    When we gather information we need to "scrape" not "scrap"
     
    rozel likes this.
  11. Inikad

    Inikad Active Member

    Corrected. English is not my own language so I make some mistakes. ;)
     
  12. Mabon

    Mabon Active Member

    Not picking on anyone here, but the mistake appears regularly not only this site but also on the Zidoo box itself ;)!!!
     
  13. Inikad

    Inikad Active Member

    It’s ok, I am good with the idea of using the correct words to explain what I want to. :)
     
  14. ATROX

    ATROX New Member

    9. MP does not support UTF-8 when reading tag files. Only English is displayed normally. National symbols (Russian for example) is displayed as Chinese characters.
     
    Mabon likes this.
  15. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    It is question for me if it is an error. Clear Application Data could in fact work without a restart. So does it function as it should without restarting?
    A factory Reset obviously needs a restart to get back to defaults.
     
    Last edited: Jan 2, 2021
  16. Inikad

    Inikad Active Member

    Yes, it seems to work without to have to restart.

    But
    , the next time that you will turn on your Zidoo, you will have to go through the "Welcome initial settings" on the screen. So, better to restart right away as it used to do with the Z9s or Z10 IMHO.
     
  17. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Correcting English in a friendly way should not be a problem. Never too old to learn. We all make mistakes there and indeed some English on the box itself is annoying. A good example is using Open/Close when toggling On/Off is meant (maybe the same when translated to Chinese?)

    Occasionally mail some language errors to Zidoo myself.
    http://forum.zidoo.tv/index.php?thr...nguage-corrections-rtd1619dr-models-fw.84852/
    Opened a new topic for that.
     
    Last edited: Jan 2, 2021
    Mabon likes this.
  18. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Thanks for testing. I changed the bug to either do a restart implicitly or better just give the message directly as a response to the command!
     
    Last edited: Jan 2, 2021
  19. Whitfield

    Whitfield Active Member

    I noticed that the explorer's "Grid View" setting goes lost after a reboot, where the view defaults back to "List View".
    This is for browsing NFS shares. I would not know for SMB as I don't use this.
     
  20. Inikad

    Inikad Active Member

    Not a big issue but I have noticed that from time to time (a random bug because this is not every time), the Weather app doesn't start automatically with your City. You have to open the app and then go back to the main page without doing anything else and the choosen city is back.
     

Share This Page