Recommended Settings and other useful stuff for RTD1619 Players (VS10 SDR PDF added)

Discussion in 'HDD Media player(RTD 1619DR)' started by Markswift2003, Oct 21, 2020.

  1. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Really not sure what's going on here.

    The whole point of the custom EDID is that the box is always presented with an EDID regardless of the on/off state of any HDMI sinks (amps/displays etc) upstream of it.

    So even if the amp/display are turned off, the Zidoo still sees an EDID.

    Where you say that switching the Zidoo on after the amp/display have fully booted works is doubly confusing because that's the only case where there could theoretically be an issue - say the EDID apk didn't start for some reason.

    I've tried to replicate this by both booting the Zidoo with and without an external EDID and from both hot and cold starts but I can't - it always honours the custom EDID and boots into VS10 SDR (Settings/Display/HDR > VS10 for all content).

    I've also used the EDID from the link I posted to make sure Mega didn't corrupt anything, but EDIDs have checksums so it either works or it doesn't - obviously in my case the file was fine.

    So the only thing I can think is that maybe there's an issue with the boot process - Maybe try updating the firmware and if you're on the latest you should be able to overwrite it.

    Other than that I can only think a factory reset (after making appropriate backups of HT etc).
     
  2. vddan

    vddan Active Member

    Nothing serious with the edids, sometimes the zidoo does not take into account the edid in place ........ it is enough to disconnect the button from the top and followed it to reconnect it, so that it takes it into account!
    Just a little 'bug'
     
  3. Colmas

    Colmas New Member

    Thank you for taking the time and effort to respond to my issue.

    I will try updating the firmware, although I am on the latest version and see what happens.
    Again, last night, I went from a Vodafone activity, after about an hour of use, and then into the Zidoo activity and all was OK. It is puzzling, in that when I boot straight into the Zidoo activity and see washed out images in Rec. 2020, the custom EDID is on for Rec. 709, and VS10 is set for all content. But it seems to be ignored, and only accepted after I turn the custom EDID OFF /On again.

    Thanks again
     
  4. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    When you say "Activity", I assume this is a macro - a sequence of programmed events?

    I use Crestron where we have "Steppers" to do this with commands and delays - is this similar to what you're doing?

    If so, can you provide a list similar to the below - then perhaps I can replicate that here and see if I can figure out why the EDID doesn't persist...

    upload_2022-12-2_9-11-28.png
     
  5. Colmas

    Colmas New Member

    Although I was on the latest firmware, I reinstalled it again over the existing one. Fired up the system, and the Custom ERDID stuck! Success at last. However, I have only tried it once, and I'll keep an eye on it over the next few days to make sure that it has in fact stuck. Thanks for the suggestion.

    Fo the sake of completeness, my list of commands for the Zidoo via the Harmony Elite is:
    Zidoo Activity.jpg

    Thanks again for your help, much appreciated.
     
  6. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    So obviously absolutely no red flags in that sequence - let me know how it goes over the next few days...
     
  7. 3DBuff

    3DBuff Active Member

    Hi @Markswift2003 and everybody else in this forum

    After soring out Samba server issues between two Zidoo's Z9X I had some time to explore ability of scaling down 4K HDR to my HD projector Home Cinema 5030UB 10bit!

    Using VS10 I'm getting image that is brighter, blacks lifted about 4 points. Typically this is not a problem since Zidoo has adjustment dedicated to this function under "HDR to SDR" picture parameters. Adjusting brightness from default 32 down to 29 or 28 corrects this problem. This works for most of the movies. In some rare instances the image is still bright using VS10 engine. After further exploring I found that it is not in this dedicated HDR to SDR format but rather still in standard SDR mode that effects all regular HD movies including Home Screen and HT poster wall.

    Below is correct format "Movie B", DV scaled down to my projector 1080p, SDR 10 bit.

    Screenshot_20221204-105851_B.png

    Screenshot_20221204-105544_B.png

    Please note image below showing HDR to SDR during the movie. This leads to dedicated adjustment used for fine tuning of converted movies.
    Screenshot_20221204-110108.png

    Now below I have Movie A. Very similar 4K DV scaled down to my projector.
    Screenshot_20221204-102626_A.png

    Screenshot_20221204-103151_A.png

    This generates bright image even if the specific HDR to SDR is adjusted. Please note below lack of HDR to SDR function in menu during the movie. It runs in regular format. VS10 is active but brightness adjustment darkens all HD movies Zidoo Home Screen and poster wall.
    Screenshot_20221204-105418.png

    Screen capture does not reflect brighter image on my projector. Settings on projector are the same and signal appears to be the same for both movies A and B with projector brightness at 0.
    I can't find any real difference between both files other than resolution.
    Adjustments for Color and HDR functions in Zidoo do not appear to make any difference to this issue. Movie A is always brighter unless I change global brightness for all and movie B is always OK using dedicated HDR to SDR picture parameter.
     
  8. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    What setting do you have for Settings/Display/Colour Settings/HDMI Range?

    (I assume you're using latest or at least recent firmware?)
     
  9. 3DBuff

    3DBuff Active Member

    Latest firmware. HDMI range is 16-235 in Zidoo. Auto range on projector. It doesn't make any difference if I set it to Auto in Zidoo. I think it only goes worse, even brighter if I keep playing with HDMI range.
    I'll take a screenshots and post other settings when I get home. I had it as per your recommendation from the first post and then I experimented with it a bit. I think I left it in auto as much as possible. Automatic EDID (not custom). No matter what Movie A uses standard global picture parameter setting with VS10 logo on at the start.
    I'm assuming that brighter picture and lifted blacks are from HDMI range 16-235 applied across 10 bit range and projector not aware of it. It only happens when playing 4k HDR movies.
     
  10. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    No - an HDMI range of 16-235 in 8-bit is 64-940 in 10-bit and that's how the video is encoded. It'd be more accurately labelled as "Limited" and "Full" range - but the problem with that is that people tend to assume "Full" is better which is incorrect.

    For video, 16-235 is the correct setting for both the source and the display, so although Auto should get it right, sometimes it doesn't so it's always worth setting it to 16-235 (or "Limited") in both the projector and Zidoo.

    Also, if you've messed with the HDMI range on the Zidoo, always switch to another HDR mode (eg Auto) and then back again because sometimes the logic gets mixed up, particularly with VS10 SDR.

    If it's all set up correctly you really shouldn't see raised blacks anymore - it used to be an issue with VS10 SDR (and to a certain extent, VS10 HDR) but not for a long time now. I'm using VS10 SDR with my projector at the moment and don't see this at all and test patterns bear this out.

    I guess the thing is that since VS10 and Dolby Vision, there are so many parameters that there's no one size fits all anymore - it can be tricky, but once set up properly, it works like a charm.
     
    vddan, 3DBuff and TV11 like this.
  11. 3DBuff

    3DBuff Active Member

    Don't know if I have anything handy like a test pattern with 4K HDR video to start VS10 scaling and the same pattern for 1080p HD video. It would show the brightness difference. 4 points brightness adjustment on Zidoo from 32 to 28 is a lot. Internal screen capture from Zidoo is good and doesn't show it. Only projector output. I'll make sure that projector is on limited range and report back.
     
    Markswift2003 likes this.
  12. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    If you want some good free HDR test patterns I can recommend Mehaniks:

    https://www.avsforum.com/threads/hdr10-test-patterns-set.2943380/

    For SDR I use:

    https://www.avsforum.com/threads/avs-hd-709-blu-ray-mp4-calibration.948496/

    I also use R.Masciola's patterns:

    https://www.diversifiedvideosolutions.com/

    And of course S&M, although they're a PITA because they're on disc.

    http://spearsandmunsil.com/
     
    3DBuff likes this.
  13. Eric Rozzell

    Eric Rozzell New Member

    Is there a way to turn off the shield Z9X with the remote? A special setting somewhere that I’m missing maybe? 154C15EC-C06C-420E-BA3C-7AFA821E75DF.jpeg
     
  14. 3DBuff

    3DBuff Active Member

    @Markswift2003 you were 100% correct here!

    HDMI range on the projector was messing it up. I always had it in auto for years. Never seen a problem with it and it would switch to full range automatically for occasional PC usage. 10 bit input hat to trigger it into full range. Both movies A, B and all my movies are back to default settings on Zidoo.

    The question about both DV movies A and B not treated equally by Zidoo VS10 is not that much important now since both look very good without any adjustment.

    From quick browsing movies and testing “VS10 for HDR and DV” works best for me. “Auto” puts Realtek engine for HDR10 UHD structures. Los in brightness and distorted colours in dark areas compared to VS10. Using VS10 for all is forcing it on 4K SDR content. Not needed, I can see some fluctuating brightness for no reason.

    Pictures below are quick from my phone hand held 0.5s manually locked exposure to show the difference when pj was in auto or limited.

    A801D421-C927-4B89-AB75-5B71C70DB830.jpeg

    F2D4A0BD-7713-490A-B810-7A89D38FD2BF.jpeg
     
  15. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Glad it's all sorted.

    Really not sure why those two movies should behave differently - possibly the signal_full_range_flag in the RPU but that shouldn't actually matter since the RPU is irrelevant once it's SDR and would always be limited.

    The Realtek HDR to SDR engine isn't bad at tone mapping, but it's absolutely awful at colourspace conversion and always has been way back to the 1295 boxes, so was never worth using.

    As you say, there's no point using VS10 for SDR content, although if you have a projector like mine with a 12-15s HDMI resync, it's useful to process everything in VS10 to reduce resyncs to virtually zero.
     
    3DBuff likes this.
  16. B0RN

    B0RN Member

    lol did you mean to call it a Shield Z9X? hehe
    BTW, not sure what you are asking here with the shutting down screenshot. You press the power button while Z9X is on and it will shut down? Unless yours just happened to always be stuck after the shut down screen? If so, you might do a hard reset on the device because that is not normal behavior of the device to just be stuck like that.
     
  17. Fade

    Fade New Member

    Hi,

    Just got my first Zidoo :) (z9x). I've followed the guide on the first page (running latest fw), and it's connected directly to an LG oled c1. But with HDMI-mode: auto I get distorted DolbyVision (purple picture and such (source=mkv)), if I choose to use VS10 player for DV only it works without issues.

    Should it be like that? (just trying to understand why it happens)
     
  18. Eric Rozzell

    Eric Rozzell New Member

    Yeah got a bit wrapped around the axle with that post. I meant the Zidoo Z9X of course. Pressing the power button does absolutely nothing. I have to use the switch in the rear. The shut down screen appeared only once, and i used the rear switch then too.

    EDIT——It seems to be working now. I need to be outputting an image then I can see the shut down sequence.
     
    Last edited: Dec 6, 2022
  19. B0RN

    B0RN Member

    Try doing a factory restore and see if that helps, write down your settings first if are worried about losing them. If you have done massive work with posters already, do a Backup of that too first.
     
  20. 3DBuff

    3DBuff Active Member

    Hey Mark last question.

    To summarize and finish off discussion about the HDMI range. When converting from HDR to SDR using VS10 engine and 10 bit display, wouldn't this be beneficial to use full range on both ends Zidoo and projector to maximize range to the limit?
     

Share This Page