Recommended Settings and other useful stuff for RTD1619 Players (VS10 SDR PDF added)

Discussion in 'HDD Media player(RTD 1619DR)' started by Markswift2003, Oct 21, 2020.

  1. ZIDOO2020

    ZIDOO2020 New Member

    If your TV support HDR10+ but your Denon does not support HDR10+, you still can get HDR10+ from Zidoo if you are using a HDMI splitter to split the display (via HDMI out 1 to TV) and sound (via HDMI out 2 to Denon).
     
    Andy Lim likes this.
  2. Dokmov

    Dokmov New Member

    Heya guys,

    I need your help.Just got the Z10 Pro to replace the Nvidia Shield and Plex for local streaming of 4k MKV rips from NAS.

    I have used the recommended settings from page 1 and can’t seem to be getting Dolby Vision on my Sony AG9.

    Same MKV has no problem being displayed in Dolby Vision through the Nvidia Shield.

    I am using the HDMI cable that came with the Z10.

    Any help is greatly appreciated.

    Thanks
     
  3. Dokmov

    Dokmov New Member


    Update:Managed to get it working.It seems some of my MKVs does not trigger Dolby Vision on the Z10 Pro but others did.At least I know now it is working.Will dig in further to see which DV profiles does not work on this unit.
     
    TV11 likes this.
  4. Andy Lim

    Andy Lim New Member

    Yes, thats right! Thx! I didnt think of that.
     
  5. rozel

    rozel Well-Known Member

    As you probably know, there are splitters then there are splitters. Just be careful with your choice if you are going down this route - I use a Vertex2 so don't have this issue but I am sure there will be members on here who will be able to recommend a suitable piece of kit
     
  6. Pate2

    Pate2 New Member

    Hello and happy Thanksgiving everyone! New to this forum and just received a Z9X with external WD Elements 14TB hard drive about a week ago. Sadly though, I played my first MKV file from a ripped 4K James Bond Spectre UHD disc and compared it to my Roku Ultra streaming version of the same movie. The Zidoo definitely seemed more dull and dim than the streaming version, which is the opposite of what I expected. I realize that I must have some settings incorrectly set. I was about to make changes based on the opening post from this forum section, but it seems that the recommendations may have changed (maybe not). I was hoping that you could point me in the right direction. The more that I read here; the more I started to get lost. FYI, I have a JVC RS4100, Denon X6500H and 8k HDMI cords with no splitters or anything else in between. The Zidoo should be better than a 4K Roku stream with detail, clarity and performance, right? If not, I have wasted a lot of time ripping movies.

    Thanks in advance for any help!!!
     
  7. rozel

    rozel Well-Known Member

  8. Phil181

    Phil181 Active Member

    As mentioned above, also find Settings, then Update, tick Beta so you will get the latest firmware update :)
     
  9. Schumy

    Schumy Member

    have you tried the video parameter settings in the advance menu during playback? there you can adjust brightness, contrast, hue, etc, it should make a huge difference. good luck.
     
  10. I won't be surprised if this has already been brought up in his thread before, but I'm having an issue with the 'Match Resolution' setting where SD/HD videos that have a 4:3 aspect ratio are output by the Zidoo at 3840 x 2160 instead of their native resolutions.
    I have noticed this unusual behaviour with firmware going all the way back to when I first got my Z9X but as very little of my content is 4:3, I've never bothered to follow it up before. Multiple updates, resets & box flashes later, the issue persists. Even now, I can't say I care that much, but it would be nice to know what's going on & if it can be fixed.
     
  11. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Depends on resolution vs framerate - for older formats, for example 480i, 576i, lega HDMI modes are very restricted - basically 60/50Hz only - so if the file isn't 480i60 or 576i50, the Zidoo must choose a legal HDMI resolution.

    Arguably it should maybe go to the next available resolution, but equally valid if going to the native EDID resolution - in this case, 4K.

    Similarly for 720p - that must only be 50/60Hz otherwise another resolution must be output to keep the HDMI mode legal.

    It can be confusing as hell.
     
  12. That's an understatement :D

    Thanks for the explanation, Mark.
     
  13. Pate2

    Pate2 New Member

    Update. I did change settings based on the first post. It was late last night, so I need to double check everything. When I changed the HDMI setting from Auto to 16-235, it definitely helped with the brightness. Unfortunately, when comparing the same movie "Wonder Woman" in UHD disc, versus Roku Ultra and Zidoo, the Zidoo finished last place. There were more details and highlights present in the disc version. Therefore, I believe that the settings aren't correct still. I haven't done the Beta update, but will do that if you feel it is stable. I will keep on fiddling. Thanks for the help!
     
  14. Phil181

    Phil181 Active Member

    Definitely install the latest beta firmware. Has been well received since the update (see separate thread here).
    Tick beta in the Update Settings and it should come down over OTA for you :)
     
  15. B0RN

    B0RN Member

    Can somebody pls tell me the default setting for DV - whether its set to Player Led or TV Led? I have changed it a few times but want to go back to default without having to reset all settings, thanks.
     
  16. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Default is TV Led.
     
  17. B0RN

    B0RN Member

    Awesome, thanks!
     
  18. Colmas

    Colmas New Member

    I have followed the procedure as advised by Mark Swift, and the issue I am having is that the Custom EDID is not sticking. It defaults to Rec.2020 output which results in a washed-out image. If I turn off custom EDID, and then turn it back on again, everything is OK and gives a beautiful image. This pretty much happens every time I turn the system on.

    However, I have noticed that if I physically turn off the Zidoo (hard switch at back), turn on the PJ and receiver, wait for a blank screen to come on (`40 sec), then turn on the Zidoo, the custom EDID sticks. I have tried programming a 45 sec delay on my Harmony Elite, but it doesn't seem to work, as the Zidoo still starts at the same time as the other devices. It appears that the PJ has to be on well ahead of the Zidoo for the EDID to stick. It also works if I run a DVD or Vodafone TV activity on my Elite and then transfer to the Zidoo activity.

    Not sure what is going on, and any advice would be greatly appreciated.

    Cheers
     
  19. Deano86

    Deano86 Active Member

    The whole point of the custom EDID is that the Zidoo doesn't need and/or ignores the EDID handshake with downstream devices... it simply uses the information it has stored in that EDID. I would delete whatever custom EDID you are attempting to use and try again. .. something is wrong with it or that EDID you are using is incorrect for your setup.
     
  20. Colmas

    Colmas New Member

    Thanks for the reply.

    Yes, I understand what you are saying, and it's possible that the custom EDID has been corrupted. I am using the Rec.709 custom EDID, recommended by Mark Swift in the EDID thread. I will re-download it and try again. For some reason the custom EDID that I am currently using is ignored, unless the PJ is on well ahead of the Zidoo. When it's working it works beautifully and is only an issue at startup.
     
    Last edited: Dec 1, 2022

Share This Page