Jellyfin AndroidTV Client Thread

Discussion in 'Jellyfin for Zidoo' started by andy22, Jun 18, 2022.

  1. Does anyone else get the error "ContainerBitrateExceedsLimit" when trying to play some 4K UHD rips?

    I had that issue with Ronin last night and have had it with some others like Shrek. It tries to play and I can hear the audio for a few seconds, but then it fails.

    Emby can play the same file, but it transcodes to very low quality and won't let me navigate the file.

    Using the Media Center App on the Z9X I can play the same files and they work fine.

    Everything is on my Synology NAS with a separate server running Jellyfin. The file folders are all mapped directly to the NAS.

    EDIT: I was able to fix this pretty easily after all. I'd only been messing with server settings, but the in app settings of the Jellyfin Zidoo app has an option to specify bandwidth maximums and was at 100, which explains why only some wouldn't work.
    Last edited: Jul 1, 2023
  2. Sledgehamma

    Sledgehamma Well-Known Member

    They changed the API somehow. Yay n the loading screen there is no background or logo any longer. It only happens when the file was already indexed by HT.
  3. Nathan W

    Nathan W Member

    Yep you are right, I didn't notice this initially, was just worried about the app actually "working".
  4. Nathan W

    Nathan W Member

    I'm not experiencing this issue on original v0.15.11 app on the Z9X Pro (new player with Android 11) Only thing not working for me is chapters. Can anyone else confirm? It's a trade-off but I don't like to wait an hour for HT to scan my library on every boot or finding a new episode, or wait for jellyfin server to finally become incompatible with custom player. Library transversal on new app is also much smoother.
    Last edited: Jul 7, 2023
  5. Hippoponderous

    Hippoponderous Active Member

    Well, based on this, I uninstalled Andy's version & tried the official v0.15.11 on my Z9X.
    So far so good. I've tried several files (both movies & episodes), all of which call the Zidoo player smoothly & track playback/resume points. The only weird behaviour I've noticed is that while a progress bar will appear on the file in its relevant category ('Latest Movies/Shows'), the file itself will not appear in the 'Continue Watching' section until the app is restarted.
    Also, if an episode is played from the home screen 'Next Up' section & stopped part-way through, it will immediately disappear from 'Next Up' & only reappear on the home screen 'Continue Watching' when the app is restarted. Overall, not a big deal.
    I can skip chapters during playback using my remote &/or select chapters from the file's home screen chapter menu without issue.

    For me, It was worth making the switch to the official app, however, I will miss some of Andy's nice GUI customisations.
  6. So I went ahead and installed this. I can't get it to call the Zidoo player no matter what setting I change.

    I'm on .62_g firmware, is that what you're on as well?
  7. Is yours able to call the Zidoo player too?

    Trying to figure out what I'm doing wrong before I just go back to Andy's app.
    Last edited: Jul 8, 2023
  8. Hippoponderous

    Hippoponderous Active Member

    That strange. I'm on .62 as well. Non-g version, though I don't see how that would make a difference.
    What's the behaviour when you try to play a file?
  9. Thanks for the reply. I agree that small firmware difference shouldn't matter.

    So if I leave the app as is, it plays fine, but it's using the Exoplayer, not the Zidoo player. The VLC beta player also works fine, but again not using Zidoo player obviously.

    When I try to set it to use the external player in the Jellyfin app options, it immediately says cannot play file no matter what type of file I try. Doesn't seem to be attempting to "call" anything, just a pop up right away. I also tried rebooting a couple times.

    If I tell it to ask me every time what player to use, it behaves the same when I select external player and says it cannot play file.

    Kind of amiss what it could be if it's working for two of you as there's only so many settings to configure. Might try a re-install, but I doubt that's likely to fix anything.

    Emby works fine for calling the internal player as did Andy's version.
  10. Hippoponderous

    Hippoponderous Active Member

    Do you have the direct path set in the server library settings?
    If you didn't, then Andy's version wouldn't work for you properly either (I'm assuming that you do, but just in case...).
  11. Yes, I did have that part set correctly. Andy's app was working great for me, but another easy fix was found here, guess that's good lol.

    I don't know if it was defaulted or I'd changed it without thinking, but max bit rate in Jellyfin was on Auto that appears to have been the hold up. As soon as I set that to 120, everything played correctly. What's weird about that is I was sure I tried many variations of file sizes/bit rates, but when I went back to it just now and before changing that setting, some were playing, but some not. I reduced it to playing sub 20gb files or so fine, but anything that was a big blu ray or 4k rip wouldn't. it fixed it nonetheless, so whatever. Thank anyways!
  12. Hippoponderous

    Hippoponderous Active Member

    Well done! Great troubleshooting (feels good when you can work these things out yourself, doesn't it :))

    Now I'm keen to hear if you have the same user experience with the official app as @Nathan W & I have had.
  13. Thanks! And agreed, figuring it out yourself also helps to understand it better if things pop up again. I was probably hasty coming here so quickly but bouncing it off others often helps.

    I will definitely report back. I am liking the look of it already as it feels snappier and has some decent customization.
    Hippoponderous likes this.
  14. chadamir

    chadamir New Member

    I'm curious for those using official app, have you confirmed it's not transcoding?
  15. Nathan W

    Nathan W Member

    Yes, I'm getting both DV and Dolby Atmos through it which would not happen if it was being transcoded in anyway.
  16. chadamir

    chadamir New Member

    Only problem Im having is because lg doesn't support dts, I can't get it to transcode.
  17. Well, I don't want to speak too soon, but after sorting my initial issue, I think this new Android TV version appears to render Andy's version unnecessary, which is really encouraging for those of us relying on Jellyfin.

    Much snappier and more customizable leading to a more appealing look for me.

    Ran through various content last night and I can't say I noticed any specific problems. Getting Atmos, DV, HDR10+ and 3D no problem.
    Sledgehamma likes this.
  18. Sledgehamma

    Sledgehamma Well-Known Member

    Does it support the loading screen with logo/fanart as well as playback sync and resume?
    Last edited: Jul 9, 2023
  19. Gilgamesh

    Gilgamesh Active Member

    I tried the official Jellyfin but everytime I stopped a video I get popup message if I want to mark the video as played or not, annoying, also won't show up in continue watching status, better to use PlexToZidoo that just works no issues. :)
  20. Both working for me, at least if I'm understanding the first question correctly. Jellyfin logo flashes on program start and movie backdrop on content start up.

Share This Page