Jellyfin AndroidTV Client Thread

Discussion in 'Jellyfin for Zidoo' started by andy22, Jun 18, 2022.

  1. nc88keyz

    nc88keyz Active Member


    Short Answer: I should have went to the github page where apparently, they devs of Jellyfin decided it would be good for many to remove "delete media from the "Android TV" client, but have decided to add it back after some mild backlashing. It requires a lot of code rewrite and while they did decide to add it back after fixing the lines of code having to do with permissions, it is NOT available as it will make a welcomed re-appearance in the v 0.16.x cycle of updates to Jellyfin for Android TV. We are currently at v 0.15.6 as of 4/20/2023. I knew I was not crazy, It works on Appletv and also via android phone, just not android tv clients such as Nvidia Shield, Tivo Stream 4K, and apparently the code that is used for our Jellyfin Client which I believe is taken from the official Jellyfin Android TV code base even though the Zidoo uses Android Mobile OS. or a highly customized version of Android. I believe it is a mobile variant because of the services that run and the way it handles apps for Android v. Android TV format. Not so short, but bottom line. We wait. for v 0.16.

    If you dont want to loose the feature, dont update your clients or server side as that affects compatibility sometimes.
  2. Hippoponderous

    Hippoponderous Active Member

    I have an unusual playback problem with a single TV series that results in the "Zidoo player failed...check network path substitution...sharing permissions..." error message.

    The problematic series/folder is in the same correctly set up parent directory that contains 99 other series, none of which have this playback/network path issue. The series also plays fine via my other Jellyfin clients.

    The issue seems to be the folder or series itself (metadata maybe?). Trying to play dummy files in the same folder results in the same error message. Same if I try renaming or recreating the folder. I've checked the folder properties on my Synology NAS & there's nothing out of the ordinary. By default, it should inherit the permissions from the parent folder.

    If I remove an individual episode from the problematic folder & place it in a different series folder (giving it a new dummy episode name/metadata), it plays without issue.

    I've also tried re-scraping the series (using different scrapers), as well as deleting it from & re-adding it to Jellyfin to no avail.

    The series is The Midnight Club (2022) & is scraped, like all my media, by TMM.

    Does anybody (@andy22?) have any idea WTF is going on here?

    I don't use HT but as an experiment, I thought I'd add this troublesome series/folder as a source to see what happens. As it turns out, HT refuses to scan that folder & add it to the library (it did with a couple of other series I tried, though). However, while HT won't scan or add that folder, I can play those files in Media Center.

    It should also be noted that this series was not the most recent series added to the parent folder. More recent series/episodes play without issue.

    I'll post this issue in a more appropriate thread.
    Last edited: Apr 22, 2023
  3. Six66Mike

    Six66Mike Member

    No errors or impact to issue quality if you pass playthrough to the Zidoo. Have not tried using Jellyfin as the playback channel, so couldn't comment on that.
  4. lightsout

    lightsout Member

    For some reason the "trailer" button only shows up on a handful of movies. I am not talking about local trailers but Youtube. On a few random movies it is there and works as expected opening up my YT app, smarttubenext. But for the major majority, even big blockbuster movies it just isn't there. Anything i can do to fix this?
  5. HDGuy

    HDGuy Active Member

    Does Jellyfin support HDR10/HDR10+/Dolby Vision and DTS-X/Atmos tags yet?
  6. lightsout

    lightsout Member

    Are we dead in the water again. I'm thankful for this app, working great today.
  7. Hippoponderous

    Hippoponderous Active Member

    Was wondering the same thing. The last status update from @andy22 was nearly 3 months ago. :(
    At least it's not buggy & has been working solidly & reliably since its last release. :)
  8. lightsout

    lightsout Member

    Yeah I think the last release was from October, I am worried that a JF update will break it, so far so good!
  9. Ya I love this app and is my go to over Emby and Plex. Really hoping support continues as the Emby app fails on some files and the Plex app requires too much setup in order to be able to use the internal Zidoo video player.
  10. HDGuy

    HDGuy Active Member

    I guess I answered my own question by installing it- no HDR or Atmos/DTS-X medata tags to speak of, which is a bummer because even the iPad client has HDR tags.

    I guess it’s up to whoever is working on the Zidoo client to implement it.
  11. lightsout

    lightsout Member

    I've been a long time Emby user but this app has had be using JF more. Emby not up to snuff on the Zidoo.
  12. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    As far as I know it's a server issue not a client issue.
  13. HDGuy

    HDGuy Active Member

    Same server, the iPad client clear showed HDR for appropriate content, no Dolby Vision tag.
  14. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    I thought that was the point - that Dolby Vision, Atmos and DTS-X tags were missing?

    HDR tags are there on all clients, and as I say, I think that's a server issue.
  15. HDGuy

    HDGuy Active Member

    I didn’t see any HDR tags on the Zidoo client.
  16. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    At the top:

    Six66Mike likes this.
  17. HDGuy

    HDGuy Active Member

    Not on mine for some reason, this was on all titles. I was using my UnRaid server, but that shouldn’t matter because my iPad showed it correctly.

    That said, without all the extra tags that HT4.0 offers I’ll stick with that. I don’t do any transcoding.
  18. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    That's odd - I get HDR on HDR10, 10+ and DV and SDR on SDR - always have as far as I know.
  19. HDGuy

    HDGuy Active Member

    There are a number of different JellyFin servers for UnRaid, I was using LinuxServer’s package (updated yesterday) because it offers some hardware encoding, but I can try the official Jellyfin docker and see if that works properly. It only takes a few minutes to setup so it’s not a big deal.
  20. Gilgamesh

    Gilgamesh Active Member

    I'm using Linuxserver docker on my unRAID server and no problem with showing HDR/SDR tags, though I currently switched over to HT4.

Share This Page