EDID thread (FW v6.1.10 onwards) (Updated)

Discussion in 'HDD Media player(RTD 1619DR)' started by Markswift2003, Mar 18, 2021.

  1. Ozzyoz

    Ozzyoz Member

    For min. nits you put zero ?
     
  2. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    In the Dolby Block?

    Yes.
     
    vddan and Ozzyoz like this.
  3. Nathan W

    Nathan W New Member

    Anyone have any advice for modifying an EDID? The provided EDIDs on initial post fixed me getting LLDV working properly but it makes CEC all screwy and can no longer turn everything on and off with a single button. So I want to take DV settings from that and include that in my dumped EDID of the actual device. Is that possible? Would that solve my issue? My googling did not find any tools for this but maybe I'm looking in the wrong place.

    Setup is Z9X <-> Samsung HW-Q900a + wireless rear speakers <-> Samsung S95B
     

    Attached Files:

    Last edited: Jun 9, 2022
  4. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    I use Deltacast E-EDID Editor and Advantiv EEditGold to edit EDIDs.

    Unfortunately, because that Samsung EDID is a combination of your TV and the Soundbar (I assume it's a soundbar) and it's created by the soundbar, there's not enough room left in there to add a Dolby Block.

    If you send me just the TV EDID (Z9X > TV) I can try to manually add the audio modes from the soundbar and a Dolby Block to see if I can crowbar it all in - problem is that EDIDs are only 256 bytes which is bloody stupid! - well actually, you can extend that with an additional CEA extension, but most equipment will then ignore it...

    What confuses me is that CEC is not defined in EDID so using a custom EDID should not affect it.
     
  5. Nathan W

    Nathan W New Member

    I have attached it below. I double checked and redid everything's handshake and situation is the same.
    No custom edid= z9x turns on soundbar which turns on tv, z9x turns off everything
    Custom edid = z9x turns on tv and doesn't touch soundbar, z9x turns off everything
     

    Attached Files:

  6. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Ok - that EDID is also too full to allow addition of a Dolby Block as well but I think I figured it out...

    The HDMI 1.4 VSDB (Vendor Specific Data Block) contains the physical address of the HDMI port to which the source is connected.

    This is also the CEC address, so I've changed the custom LLDV EDID to reflect the same address as the soundbar+TV EDID you originally posted.

    So try this and see what happens:

    https://mega.nz/file/FeYkGbrK#F-IvfzURwrTp0P_wzd6n9pJn2CqUgtVARItGI8Fja3U
     
    Letmein likes this.
  7. Nathan W

    Nathan W New Member

    This worked perfectly. Everything is functioning as it should, with HDR10+ and LLDV working. Compared content with custom edid on and off everything seems correct. Appreciate the help.
     
    Markswift2003 likes this.
  8. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Cool - I've learnt something there too - never figured that the HDMI 1.4 address would affect CEC, but it's kind of obvious if you think about it...
     
  9. Nathan W

    Nathan W New Member

    *inserts the more you know gif*
     
  10. David Arce

    David Arce New Member

    Thanks a lot Mark! This EDID you provided for the Epson 8300 worked perfectly with my Epson 4010 for using LLDV. I couldn’t achieve a good picture quality with any of the Zidoo’s tone mapping options until I read your post. Now it’s great! Really thanks a lot!

    The only problem I am facing at the moment is that I can’t use DTS X (DTS HD Master Audio) while using this EDID. It downsamples the audio to DTS core. I have been trying to learn about editing EDIDs but it has been above my technical skills… and I also have a Mac, so there aren’t many software options for this. If you could point me into the right direction on how to edit my own EDIDs for using LLDV on my setup, or if you could help me editing my EDID as you did with the 8300, I would be eternally grateful! Thanks in advanced. I attached my EDID to this post with every device turned on that I use with the Zidoo Z10 Pro.
     

    Attached Files:

  11. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Yeah that Epson EDID doesn't contain specific audio codec information - it's just the projector one.

    Unfortunately, the EDID you sent, because it's a combination of the projector and amp, does not have any space left to add another Vendor Specific Video Block required for adding the LLDV info.

    However, attached is a more generic 300MHz EDID with full audio and an LLDV block which should work the same..
     

    Attached Files:

    David Arce likes this.
  12. David Arce

    David Arce New Member

    Thanks a lot, Mark! It worked like a charm. I really need to start learning about this. The Zidoo became a whole new can of worms for me. I was planning to return it before I found this thread. Now this will probably become my primary device. Thanks a lot for your time, Mark.
     
    Markswift2003 likes this.
  13. Piper2603

    Piper2603 New Member

    Hello, my TCL TV needs YUV420 10bit to play HDR10+ but on 4k 23~30Hz is only YUV422 what can I do? I send my EDID
     

    Attached Files:

    • edid.zip
      File size:
      400 bytes
      Views:
      1
  14. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    That behaviour is correct.

    YUV 4:2:0 is not a legal HDMI mode ar 23~30Hz. You can only use 4:2:2 , 4:4:4 or RGB at 23~30Hz

    HDMI Modes.jpg
     
  15. Piper2603

    Piper2603 New Member

    ok, than my TCL can't use HDR10+ at 23~30 Hz :(
     
  16. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    HDR10+ does not require HDMI to output YUV 4:2:0 10-bit so your TCL will play 4K23 HDR10+ just fine and the EDID confirms that.

    You may be getting confused with the fact that almost all 4K content is encoded in 4:2:0 10-bit.
     
  17. Piper2603

    Piper2603 New Member

    But it triggers HDR10+ at 4k60 and after the Zidoo switch to 23K it is only HDR
     
  18. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    I just tried your EDID (even though I knew what the result will be!) and can confirm that the Zidoo pushes out HDR10+ at 4K23 so I'm not sure what the problem is.

    upload_2022-6-28_10-16-10.png
     
  19. Piper2603

    Piper2603 New Member

    You are right, on info it says YUV444 10Bits BT2020 HDR10+ but on 23Hz HDR10+ is not triggert on my TCL, it triggers only on 60Hz with YUV420 10Bits BT2020. If I play it on the native Player from the TV HDR10+ is triggert too, but not with Zidoo Z9X
     
  20. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    I can only think it's some weird fault with the TV - the signal coming out of the Zidoo is definitely HDR10+. I can confirm that with my Vertex.
     

Share This Page